Installation Xbase 2.0.721

Von der Installation bis zur Auslieferung der Applikation

Moderator: Moderatoren

Installation Xbase 2.0.721

Beitragvon Lutz Rübe » Mo, 31. Okt 2016 13:41

Hallo miteinander,
ich teste gerade die o.g. Version und habe meine ersten, negativen Erfahrungen gemacht.
1.) Installation erfolgt zwangsläufig auf Laufwerk C:
2.) Dokumentation ist auch bei der Deutschen Version in Englisch
3.) bestehende Anwendung lässt sich nicht erfolgreich kompilieren

Zu 1) habe ich im Forum schon gelesen, dass auch euch das nicht gefällt. Als Hobbyprogrammierer muss ich es aber wohl so hinnehmen.
zu 2) ist das für mich nicht nachvollziehbar. Warum ist nur die Workbench in Deutsch, aber nicht die dazugehörige Doku ? Warum war eine Deutsche Doku für 1.9.xx möglich, aber nicht für 2.0 ? :angry5:
zu 3) das ist das schwierigere Problem für mich und hier frage ich euch um Hilfe und Unterstützung: angry9:
Mein Projekt ist so organiesiert, dass ich nicht nur für die Objekt-Dateien ein eigenes Verzeichnis habe, sondern auch für die Source-Dateien. Beim kompilieren erhalte ich die Fehlermeldung: Include file not found. Liegen die Source-Dateien aber im "Root"-Verzeichnis des Projektes, läuft alles. :banghead:
Wenn ich die entsprechenden Header-Dateien in das "Routverzeichnis" kopiere oder aber individuell mit entsprechender Pfad-Angabe in das Projekt aufnehme, ändert sich auch nichts.

Ich will mein so organisiertes Projekt aber nicht umstellen und möchte auf die Source-Verzeichnisse nicht verzichten. Was passiert eigentlich, wenn ich mal Source-Dateien aus unterschiedlichen Verzeichnissen einbaue ? Da müsste ich dann doch auf das gleich Problem stoßen.

Ich hoffe, ihr könnt mir mal wieder helfen.
Viele Grüße
Lutz
:roll: :roll: :roll:
Lutz Rübe
Rekursionen-Architekt
Rekursionen-Architekt
 
Beiträge: 117
Registriert: Mi, 02. Aug 2006 18:13
Wohnort: 24536 Neumünster

Re: Installation Xbase 2.0.721

Beitragvon Martin Altmann » Mo, 31. Okt 2016 13:47

Moin Lutz,
ich nutze die Version nicht (bin noch auf 1.9 SL1), kann dich aber dahingehend beruhigen, dass die Ursache eine ganz triviale ist:
Die Pfade haben sich in der Projektdatei jetzt geändert - sie sind relativ gesehen anders zu setzen! Näheres dazu findest Du in der Newsgroup von Alaska, Andreas Gehrs-Pahl hatte die Lösung dazu gepostet.
Ich mach' mich mal auf die Suche...

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: http://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: http://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
 
Beiträge: 12940
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin

Re: Installation Xbase 2.0.721

Beitragvon Martin Altmann » Mo, 31. Okt 2016 14:00

Gefunden:
Andreas Gehrs-Pahl hat geschrieben:So, as you are using the "INCLUDE" definition in your project file, I assume that you are using Xbase++ 2.0 (Build 462 or higher). It would therefore help if you could post your entire project file here, so we can take a look at it. For example, starting with Xbase++ 2.0.462, all file paths for source (and intermediate) files are now relative to your Target's location, while they were previously relative to the *.xpj file's location.

Pass' also bitte die Pfade im .xpj an: nicht mehr relativ zum Verzeichnis mit der .xpj-Datei, sondern relativ zum Verzeichnis der erzeugten .EXE/.DLL

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: http://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: http://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
 
Beiträge: 12940
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin

Re: Installation Xbase 2.0.721

Beitragvon Jan » Mo, 31. Okt 2016 15:03

Hallo Lutz,

1) Da hat es schon heftigste Diskussionen bis hin zu persönlichen Beleidigungen gegen und von Alaska-Mitarbeitern gegeben. Es gab mal zwischendurch eine öffentliche Aussage eines Mitarbeiters, daß man das nochmal überdenken werde. Was aber von Steffen rigoros und eindeutig verneint wurde.

2) Seit Januar 2015 gibt es die Übersetzung auch auf Deutsch, späetestens aber seit Q1/2016. Lt. Aussage von Steffen. [/ironie off]. Lt. Steffen wurde eine Profi-Übersetzerin engagiert, die das alles übersetzen wird. Im Prinzip bin ich aber schon mal froh, das es zumindest die Workbench in deutsch gibt. Wobei ich mich durch jahrelanges Arbeiten mit der VX schon an die englische Umgebung gewöhnt hatte. Mit den englischen Hilfetexten tue ich mich da dann schon schwerer. Dieses Jahr werde ich auch nicht bei den Xbase++-Tracks in Frankfurt dabei sein, ich kann also nicht nachfragen, wie denn die Timeline inzwischen aussieht.

3) Ansich sollte alles, was mit 1.9 lief, auch in 2.0 laufen. Es gibt zwar ein paar Unterschiede, wo man aufpassen muß (Browses und C-API). Ich bin aber selber letzte Woche in eine Falle getappt. Du mußt vielleicht mal kontrollieren, wie die Umgebungsvariablen von Windows aussehen. Und in der Workbench die ebenfalls kontrollieren. Beim Entwickeln werden nur die in den Workbench-Einstellungen genommen! Ich habe im Übrigen auch prg aus verschiedenen Verzeichnissen in meinen Projekten. Kein Problem. Eventuell würde es helfen, wenn Du die betreffenden Dateien mal aus dem Projekt raus nimmst, und dann per Projekt-Manager in der Workbench wieder einbaust? Vielleicht sind da ja nur irgendwelche Pfade in der xpj korrupt.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Jan
Foren-Administrator
Foren-Administrator
 
Beiträge: 11744
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle

Re: Installation Xbase 2.0.721

Beitragvon Lutz Rübe » Mo, 31. Okt 2016 15:31

Hallo Martin,

vielen Dank für Deine Antwort. Leider kann ich mit den Angaben zu "relative" Pfade nicht viel anfangen. Ich habe aber dann mal in der Doku nach den Compiler-Flags und in den Workbench-Einstellungen und zum Schluss auch in den Windows 10 Settings der Umgebungsvariablen nachgeschaut und festgestellt, dass u.a. in den Windows-Settings die Pfade in "c:\Program Files\Alaska....." gesetzt waren. Die Installation aber erfolgte in "c:\Programme\Alaska......". Ich habe dann mal mit einem "global research and replace" :lol: :lol: manuell die Pfade "Program Files" durch "Programme" ersetzt und neu gebootet. Siehe da, das war's wohl !!!

Aber da soll erst mal einer drauf kommen, dass die "Zwangsinstallation" auf C: in das Verzeichnis "Programme" erfolgt und die Settings nirgendwo anpasst.

Hallo Jan,

zu 1) hatte ich schon deutliche Kommentare gelesen. Ich wollte nur anmerken, dass auch mich das ärgert. Auf Laufwerk C: gehört für mich nur das Betriebssystem und betriebssystemnahe Daten wie z. B. Druckertreiber.

zu 2) und wo finde ich dann die deutsche Doku, wenn es sie schon seit Q1/2016 geben soll ? Wir haben schon fast Q1/2017 !!!!

zu 3) den Tip, in der Workbench die prg Dateien einzeln zu "moven" hatte ich schon angewandt, aber das hat leider nichts gebracht. Wie oben schon beschrieben war es wohl die falsche Benennung der Pfade.

Vielleicht hilft der Hinweis mit der Benennung der Pfade ("Program Files" und "Programme") anderen Usern weiter.

Besten dank für eure schnelle Reaktion.....
Lutz
=D> =D> =D>
Lutz Rübe
Rekursionen-Architekt
Rekursionen-Architekt
 
Beiträge: 117
Registriert: Mi, 02. Aug 2006 18:13
Wohnort: 24536 Neumünster

Re: Installation Xbase 2.0.721

Beitragvon Martin Altmann » Mo, 31. Okt 2016 15:39

Hallo Lutz,
OK - in Deinem Fall waren es ja auch absolute Pfade (C:\....) und nicht relative (..\..\obj\.....)

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: http://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: http://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
 
Beiträge: 12940
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin

Re: Installation Xbase 2.0.721

Beitragvon Jan » Mo, 31. Okt 2016 15:47

Lutz,

1) Das sehe ich genau so. Ich habe z. B,. bei mir alles, was irgendwie zur Programmeirung gehört, auf E:\ liegen. Nur eben Xbase++ 2.0 jetzt nicht mehr. Ärgert mich ungemein. Ich glaube, das kommt wegen der cxp-Geschichte. Weil da irgendwelche Verknüpfungen oder so zum Webserver o. ä. passen müssen.

2) Lt. Steffen gibt es die schon seit Januar 2015, spätestens aber Q1/2016. Wenn es die noch nicht gibt, dann hat Steffen wohl mal wieder etwas zu blauäugig in die Zukunft geschaut. Kennen wir ja nun schon ausgiebig.

3) Ich arbeite da auch mit absoluten und mit relativen Pfaden. Das klappt immer. Was nicht sauer klappt sind UNC-Pfade - Manfred weiß da ein Lied von zu singen. Das ist aber soweit ich weiß kein Kompilier-Problem.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Jan
Foren-Administrator
Foren-Administrator
 
Beiträge: 11744
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle

Re: Installation Xbase 2.0.721

Beitragvon brandelh » Mo, 31. Okt 2016 16:39

Also dass sich die Installation nun an die Regeln von Microsoft hält ist so verkehrt nicht ...

ABER natürlich kann man die Dateien in die bisherige Ordnung umkopieren ...

Code: Alles auswählen
@echo off
xcopy "C:\Users\...Benutzername...\Documents\Xbase++\source\*"                           "\ALASKA\ALASKA.200\XPPW32\source\*" /s /Y
xcopy "C:\Program Files (x86)\Alaska Software\xpp20\*"                         "\ALASKA\ALASKA.200\XPPW32\*" /s /Y
xcopy "C:\Program Files (x86)\Alaska Software\help20\*"                        "\ALASKA\ALASKA.200\XPPW32\book\*" /s /Y
pause

genauso wie man Projekte in den bisherigen Verzeichnissen anlegen und speichern kann ...

Die neuen Möglichkeiten gemeinsamen Quellcode für mehrere Projekte zu teilen und mehrere Anwender gleichzeitig darauf zugreifen zu lassen
führt genauso wie eventuelle neue Befehle immer dazu, dass man etwas anpassen muss, aber PBUILD /G hilft schon viel ;-)

Die Handbücher sind in englisch noch nicht fertig, da können sie noch nicht übersetzt worden sein.
Insgesamt ist 2.00 keinesfalls fertig ausgeliefert worden, aber vieles ist schon besser als bei 1.90 -
ich habe jetzt meine Projekte ohne viele Änderungen seit Monaten im 2.00 Modus kompiliert und keine Probleme.
Gruß
Hubert
Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
 
Beiträge: 13369
Registriert: Mo, 23. Jan 2006 21:54
Wohnort: Germersheim

Re: Installation Xbase 2.0.721

Beitragvon Muecke » Mo, 31. Okt 2016 18:34

Hallo Lutz

möchte mich da nicht reinmischen, aber die aktuelle Version ist 2.0 726

auch möchte ich Alaska nicht zu viel loben, aber seit wir 2.0 haben mit 726 läuft das ding.

wir haben fast alle Kunden umgestellt auf 2.0. Seit dem haben wir ganz wenige Rückmeldungen
von unseren Kunden ( wird per E-Mail an uns gesendet ).

Schöne Grüsse
Thomas
Benutzeravatar
Muecke
1000 working lines a day
1000 working lines a day
 
Beiträge: 518
Registriert: Di, 24. Okt 2006 7:19
Wohnort: Samstagern CH

Re: Installation Xbase 2.0.721

Beitragvon Manfred » Di, 01. Nov 2016 9:30

Jan hat geschrieben:Lutz,

1) Das sehe ich genau so. Ich habe z. B,. bei mir alles, was irgendwie zur Programmeirung gehört, auf E:\ liegen. Nur eben Xbase++ 2.0 jetzt nicht mehr. Ärgert mich ungemein. Ich glaube, das kommt wegen der cxp-Geschichte. Weil da irgendwelche Verknüpfungen oder so zum Webserver o. ä. passen müssen.

2) Lt. Steffen gibt es die schon seit Januar 2015, spätestens aber Q1/2016. Wenn es die noch nicht gibt, dann hat Steffen wohl mal wieder etwas zu blauäugig in die Zukunft geschaut. Kennen wir ja nun schon ausgiebig.

3) Ich arbeite da auch mit absoluten und mit relativen Pfaden. Das klappt immer. Was nicht sauer klappt sind UNC-Pfade - Manfred weiß da ein Lied von zu singen. Das ist aber soweit ich weiß kein Kompilier-Problem.

Jan

UNC Pfade waren nicht das Problem. Es mußte nur alles von der WB neu erstellt werden im XPJ. Dann klappte es. Habe es aber im Moment alles auf Eis gelegt, weil ich mal gerade wieder bestätigt bekomme, dass es immer noch nicht wirklich rund läuft.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
Benutzeravatar
Manfred
Foren-Moderator
Foren-Moderator
 
Beiträge: 16212
Registriert: Di, 29. Nov 2005 17:58
Wohnort: Kreis Wesel

Re: Installation Xbase 2.0.721

Beitragvon Koverhage » Di, 01. Nov 2016 11:03

Seit Januar 2015 gibt es die Übersetzung auch auf Deutsch, späetestens aber seit Q1/2016. Lt. Aussage von Steffen. [/ironie off]. Lt. Steffen wurde eine Profi-Übersetzerin engagiert, die das alles übersetzen wird.

Merkwürdig, die müsste doch längst fertig sein. Zumal irgendwo in den Newsgroups stand, dass sich Andreas Gehrs-Pahl um die Doku kümmert.
Gruß
Klaus
Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
 
Beiträge: 1902
Registriert: Fr, 23. Dez 2005 9:00
Wohnort: Aalen

Re: Installation Xbase 2.0.721

Beitragvon satmax » Di, 01. Nov 2016 11:13

Koverhage hat geschrieben:
Seit Januar 2015 gibt es die Übersetzung auch auf Deutsch, späetestens aber seit Q1/2016. Lt. Aussage von Steffen. [/ironie off]. Lt. Steffen wurde eine Profi-Übersetzerin engagiert, die das alles übersetzen wird.

Merkwürdig, die müsste doch längst fertig sein. Zumal irgendwo in den Newsgroups stand, dass sich Andreas Gehrs-Pahl um die Doku kümmert.


Leute, Alaska Zeitrechnung (q1/2016) * (10*y) :lol:
Gruß
Markus
Benutzeravatar
satmax
1000 working lines a day
1000 working lines a day
 
Beiträge: 776
Registriert: Do, 02. Dez 2010 20:34
Wohnort: Biberbach in Österreich

Re: Installation Xbase 2.0.721

Beitragvon Jan » Di, 01. Nov 2016 11:41

Klaus,

so wie ich das von Steffen verstanden habe kümmert Anderas sich um die Doku ansich. In dem Sinne, das die vollständig wird. Die Übersetzerin kümmert sich dann darum, das es die auf Deutsch geben wird.

Lt. Steffen sollte vor knapp 2 Jahren die überwältigend gute und umfangreiche Doku zu PostgreSQL rauskommen. Und Anfang 2015 sollte, ebenfalls lt. Steffens Ankündigung, die Doku auf deutsch erscheinen - eventuell noch nicht vollständig, eventuell noch teilweise mit Texten aus der 1.9, aber sie sollte kommen.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Jan
Foren-Administrator
Foren-Administrator
 
Beiträge: 11744
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle

Re: Installation Xbase 2.0.721

Beitragvon Koverhage » Di, 01. Nov 2016 12:49

Da sage ich jetzt mal nichts zu ;-)
Gruß
Klaus
Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
 
Beiträge: 1902
Registriert: Fr, 23. Dez 2005 9:00
Wohnort: Aalen


Zurück zu Installation und Redistribution

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast