See4Xb und SSL

Moderator: Moderatoren

Re: See4Xb und SSL

Beitragvon Scarmo » Do, 07. Mai 2015 10:59

Sehr seltsam... Hast Du schon versucht, testweise XseeSmtpConnectSSL direkt mit den entsprechenden Werten aufzurufen?

Also z.B.:
nCode := XseeSmtpConnectSSL(0, 8801, 465, "smtp.mail.yahoo.com", "martin_altmann2001", "Passwort", "Absender", "Reply", Chr(0))

Beim Benutzernamen vermute ich aber, dass die ganze Mail-Adresse (inkl. @Domain) benötigt wird.

Gruss
Marco
Benutzeravatar
Scarmo
Rekursionen-Architekt
Rekursionen-Architekt
 
Beiträge: 127
Registriert: Di, 24. Jul 2007 8:17

Re: See4Xb und SSL

Beitragvon Martin Altmann » Do, 07. Mai 2015 11:07

Moin,
danke für den Tipp! Hätte ich ja auch selber drauf kommen können!
Wenn ich die Parameter fest vorgebe, klappt es - versuche jetzt, mich schrittweise ranzutasten, bis ich den schuldigen finde.
Teste gerade nicht mehr mit yahoo, sondern mit Versatel.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: http://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: http://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
 
Beiträge: 12850
Registriert: Fr, 23. Sep 2005 3:58
Wohnort: Berlin

Re: See4Xb und SSL

Beitragvon Martin Altmann » Do, 07. Mai 2015 11:12

So ein Scheiß!!! :banghead: :banghead: :roll: Ich lese ja die :EditBuffer() der SLEs in die Variablen - schaut euch mal den Screenshot an... :doubt: :badgrin:
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: http://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: http://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
 
Beiträge: 12850
Registriert: Fr, 23. Sep 2005 3:58
Wohnort: Berlin

Re: See4Xb und SSL

Beitragvon brandelh » Do, 07. Mai 2015 12:35

und ist das etwa "*******" ?

das hätte ich ehrlich gesagt auch nicht erwartet ... Microsoft eben :roll:
Gruß
Hubert
Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
 
Beiträge: 13328
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim

Re: See4Xb und SSL

Beitragvon Martin Altmann » Do, 07. Mai 2015 13:00

Yup - ist es.
Da aber SEE4XB in die Logfiles die Passworte nicht reinschreibt, sondern durch ******** ersetzt, fiel es mir auch nicht auf!
Wieso MS? Ist doch in Ordnung so - im EditBuffer() stehen nun mal ********
Muss man halt mit GetData() arbeiten.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: http://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: http://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
 
Beiträge: 12850
Registriert: Fr, 23. Sep 2005 3:58
Wohnort: Berlin

Vorherige

Zurück zu Andere 3rd-Party-Tools

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast