HTTP Probleme

Xb2.Net von Boris Borzic

Moderator: Moderatoren

Antworten
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

HTTP Probleme

Beitrag von Manfred »

Hi,
ich versuche es mal ganz einfach zu erklären. Mir ist seit ein paar Tagen aufgefallen, das mein Webserver, den ich mit xbt2net gebaut habe, immer mit einem xppfatal aussteigt, wenn ich mit meinem Android Handy versuche darauf zuzugreifen. Nachdem ich mir das genauer angeschaut habe, stellte ich fest, das es nur passiert, wenn ich ohne https die Seite aufrufe. Was kann da wohl falsch laufen?
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15792
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 34 Mal
Danksagung erhalten: 26 Mal
Kontaktdaten:

Re: HTTP Probleme

Beitrag von Martin Altmann »

Alte Androidversion, die das neue Rootzertifikat von Let's Encrypt nicht kennt?

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

Re: HTTP Probleme

Beitrag von Manfred »

keine Ahnung, deshalb ja meine Frage hier. Ist 7.0 drauf.
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 8576
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Hat sich bedankt: 27 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: HTTP Probleme

Beitrag von Tom »

Wenn es eine XPPFATAL gibt, siehst Du doch genau, wo und mit welcher Basis-Fehlerklasse Dein Server aussteigt. Vermutlich in der Funktionalität, die einem der Callbacks OnGet, OnPost oder OnNotFound zugewiesen ist. Wo genau? Möglich und wahrscheinlich ist auch der Slot FilterRequest. Dort baut man aus den Requests, denen Anteile fehlen, die vollständigen Requests.
Herzlich,
Tom
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

Re: HTTP Probleme

Beitrag von Manfred »

hier mal die xppfatal.log von einem Vorgang
FATAL ERROR LOG
Stack Overflow
SYS Thread-ID: 1752
Module: EH
Error Codes: EH: 12 Sub: 0(0) OS: 0 XPP: 16
Call Stack of Thread 1 (660):
MAIN(49)
Call Stack of GUI Thread (828):
Call Stack of Thread 3 (1448):
@XBSERVER@I@ACCEPT(3373)
@XBSERVER@I@EXECUTE(3531)
Call Stack of Thread 4 (1664):
@XBSERVER@I@ACCEPT(3373)
@XBSERVER@I@EXECUTE(3531)
Call Stack of Thread 5 (1752):
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
skipping 989 entries
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0009(126)
@XBHTTPTHREAD@I@OPENSESSION(4631)
@XBHTTPTHREAD@I@GETCARGO(3972)
LOGERROR(357)
(B)MAIN2@0010(127)
__DISPERROR(86)
@XBHTTPTHREAD@I@RECV(4167)
@XBHTTPMESSAGE@I@RECV(5685)
@XBHTTPTHREAD@I@EXECUTE(4908)
Warning: only 255 entries of 1244 printed
File: z:\projekte\verkehrsbetriebe\webserver\webserver_dispo.exe
TimeStamp: 20210929 15:23
End of FATAL ERROR LOG.
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Frank Grossheinrich
UDF-Programmierer
UDF-Programmierer
Beiträge: 71
Registriert: Fr, 31. Mär 2017 15:06
Wohnort: Kirchheim an der Weinstraße
Hat sich bedankt: 1 Mal
Danksagung erhalten: 19 Mal
Kontaktdaten:

Re: HTTP Probleme

Beitrag von Frank Grossheinrich »

Schau mal hier.

https://www.heise.de/news/Let-s-Encrypt ... 01155.html

Würde zeitlich passen.

Grüße, Frank
ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2270
Registriert: Mi, 28. Jul 2010 17:16
Hat sich bedankt: 10 Mal
Danksagung erhalten: 39 Mal

Re: HTTP Probleme

Beitrag von ramses »

Ich denke nicht dass es am Zertifikat liegt. Das war zur Zeit des Fehler ja noch für einige Stunden gültig.
Mit Android 8.0 (aus 2016) gibt es bei uns keine Probleme.
Ich vermute eher du hast irgendwo ein Fehler in deinem Programm der zu einem Fatal führt. Hast du keine Einträge im Fehler.Log von xb2net?
Wenn es nur mit deinem Mobil Gerät Probleme gibt könnte es im Filter-Programm Code (FilterRequest) liegen....
Valar Morghulis

Gruss Carlo
Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 8576
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Hat sich bedankt: 27 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: HTTP Probleme

Beitrag von Tom »

Ich schließe mich Carlo an. In Thread 5, LogError, Zeile 357, aufgerufen von Main, Zeile 126 wird etwas (aufzuzeichnen) versucht. Ich würde da mal einen Haltepunkt setzen und mir für diesen speziellen Fall die Parametersituation anschauen.
Herzlich,
Tom
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

Re: HTTP Probleme

Beitrag von Manfred »

ok, ich habe da echt geschlafen. Das ist ja noch mein Code.
An der Stelle steht

Code: Alles auswählen

ThreadObject():GetCargo("Personalnummer")
und im Debugger wird die Fehlermeldung
"Empfänger der Nachrichten ist kein Objekt"
angezeigt. Das verstehe ich jetzt nicht
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 8576
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Hat sich bedankt: 27 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: HTTP Probleme

Beitrag von Tom »

Das ThreadObject wird überhaupt nicht erzeugt. Du hast keine Session. Es scheitert vorher.
Herzlich,
Tom
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

Re: HTTP Probleme

Beitrag von Manfred »

ThreadObject() gibt es, das bekomme ich an der Stelle angezeigt. Aber kein GetCargo().
Ich hatte vor einigen Wochen für das protokoll eine Erweiterung da eingebaut. Die klappte auch. Aber wohl nicht unter bestimmten Voraussetzungen....
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

Re: HTTP Probleme

Beitrag von Manfred »

gibt es dafür nicht eine Möglichkeit vorher abzufragen, ob es das überhaupt gibt an der Stelle? Es klappt eigentlich, das weiß ich und kann es auch in den Protokollen sehen, aber aus irgendeinem Grund klappt es nicht immer. Da ich aber an der Stelle nur eine Var abfrage, die aber auf "n.a." setze, wenn sie nicht bekannt ist, dann würde ich es einfach in dem Falle auch tun. Käme ja auf das gleiche heraus. Nur müßte ich diesen Fehler irgendwie abfangen.
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 20145
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel
Hat sich bedankt: 65 Mal
Danksagung erhalten: 29 Mal

Re: HTTP Probleme

Beitrag von Manfred »

ich habe es jetzt gegen :getvar() ausgetauscht. Das scheint dann zu klappen.
Gruß Manfred
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite
Doof kannste sein, man muß sich nur zu helfen wissen!!
Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 8576
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Hat sich bedankt: 27 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: HTTP Probleme

Beitrag von Tom »

Manfred, die Funktion "ThreadObject()" gibt Dir immer das Objekt zurück, das den aktuellen Thread ausführt. Boris hat seine xbServer-Klasse von der Thread-Klasse abgeleitet und sie um einige Methoden und iVars ergänzt. Das bedeutet aber, dass Dir ThreadObject() im Fall des erfolgreichen Starts eines xbHttpServers Funktionalitäten zur Verfügung stellt, die es sonst nicht hat - im Zweifelsfall bekommst Du einfach das ThreadObject() zurück, in dem Deine Main-Funktion oder -Klasse läuft. Und dieses Objekt kennt dann z.B. "GetCargo()" als Methode nicht, weil das eine Methode ist, die es erst in der abgeleiteten xbServer-Klasse kennt, von der es aber gerade kein Klassenobjekt gibt, weil der Server nicht gestartet wurde und Du auf Deinem Applikationsobjekt herumpimpelst. Eigenartig ist allerdings, dass "GetVar()" funktionieren soll, weil das auch eine xbServer-Methode ist.

Ich würde Dir im Zweifelsfall empfehlen, mit "IsDerivedFrom" zu prüfen, ob das ThreadObject wirklich ein Server ist. Noch besser: Fehler beim Starten der Session abfangen.
Herzlich,
Tom
Antworten