Windows 10, Xbase++ 2.0 [ERLEDIGT]

Von der Installation bis zur Auslieferung der Applikation

Moderator: Moderatoren

Antworten
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 14502
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Kontaktdaten:

Windows 10, Xbase++ 2.0 [ERLEDIGT]

Beitrag von Martin Altmann » Fr, 16. Feb 2018 17:41

Hmm,
nachdem ich nun erste Schritte mit der neuen Version von Xbase++ unternehmen will, stoße ich an die ersten Berechtigungsprobleme.
Xbase++ wird ja unter C:\Program Files (x86)\Alaska Software\ installiert. Xclass++ analog unter C:\Program Files (x86)\DS-Datasoft\VXTools\
Beides Verzeichnisse, die für mich (ich bin natürlich nicht mit Adminrechten angemeldet!) nur eingeschränkt nutzbar sind.
Natürlich habe ich mir auf den beiden Verzeichnissen Vollzugriff gegeben.
Reicht aber nicht, um die XClass++-DLL und -LIB-Dateien mit Debugcode zu erzeugen!
Unter C:\Program Files (x86)\DS-Datasoft\VXTools\Bin\ liegt die entsprechende .xpj-Datei, die ich mittels Doppelklick in der Workbench öffne. Dort wird der Treeview ordentlich aufgebaut, allerdings kommt gleich eine Fehlermeldung:
---------------------------
xclassd - Xbase++ Workbench -
---------------------------
Ein Fehler ist aufgetreten: Win32-Fehler. Code: 5.
Zugriff verweigert.
---------------------------
OK
---------------------------
Wahrscheinlich bei der Aktion:
[Hinweis] : Project file has old version. Writing backup to C:\Program Files (x86)\DS-Datasoft\VXTools\Bin\XClassD.xpj.xwb_2.2_bak
Die angeblich erzeugte Datei ist dort nicht vorhanden!
Läuft der Workbenchprozeß mit einem anderen User? Laut Taskmanager läuft der unter meinem Account...

Was kann ich tun?

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 14502
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Kontaktdaten:

Re: Windows 10, Xbase++ 2.0 [ERLEDIGT]

Beitrag von Martin Altmann » Fr, 16. Feb 2018 18:26

War wohl ein anderes Problem.
Ich habe das Verzeichnis komplett woanders hin kopiert und dann dort neu bauen wollen - ging auch nicht!
Die .xpj-Datei war schreibgeschützt - als einzige! Schreibschutz entfernt, dann ging es.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Antworten