Probleme bei der Installation durch Benutzerprofile?

Von der Installation bis zur Auslieferung der Applikation

Moderator: Moderatoren

Antworten
Werner
UDF-Programmierer
UDF-Programmierer
Beiträge: 92
Registriert: Sa, 18. Mär 2006 16:08

Probleme bei der Installation durch Benutzerprofile?

Beitrag von Werner » Di, 04. Feb 2020 19:59

Hi!

Ich habe bei zwei Kunden nach der Herausgabe eines neuen Updates das Problem, dass neben der .EXE die in der Installationsroutine (AK-Installer) mitgelieferten Dateien nicht vollständig übertragen bzw. ersetzt werden. So kommt es vor, dass das Programm immer wieder auf die früheren Dateien zurückgreift, obwohl diese durch das neue Update zwar meist nur geringfügig, aber dennoch geändert worden sind, z.B. durch Hinzufügen von eingen wenigen neuen Datenbankfeldern.

Kann dies mit den sog. B e n u t z e r p r o f i l e n zusammenhängen, die von manchen IT-Experten bei den Kunden angelegt werden? Können diese Benutzerprofile dazu führen, dass die neue .EXE nach dem Start immer noch auf die alten Datei- bzw. Datenbestände zurückgreift und damit Fehler provoziert? Was wäre in einem solchen Fall zu tun? Für einen diesbezüglichen Ratschlag wäre ich wie immer sehr dankbar!

Vielen Dank im Voraus!

Gruß Werner

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12387
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Probleme bei der Installation durch Benutzerprofile?

Beitrag von AUGE_OHR » Mi, 05. Feb 2020 6:58

hi,
Werner hat geschrieben:
Di, 04. Feb 2020 19:59
Ich habe bei zwei Kunden nach der Herausgabe eines neuen Updates das Problem, dass neben der .EXE die in der Installationsroutine (AK-Installer) mitgelieferten Dateien nicht vollständig übertragen bzw. ersetzt werden.
Frage : fordert dein Installer Admin Rechte an :?:
gruss by OHR
Jimmy

Werner
UDF-Programmierer
UDF-Programmierer
Beiträge: 92
Registriert: Sa, 18. Mär 2006 16:08

Re: Probleme bei der Installation durch Benutzerprofile?

Beitrag von Werner » Mi, 05. Feb 2020 9:41

Hi!

Nein, mein AKInstaller fordert keine Installationsrechte an und es werden auch keine Ablagen auf Windows- oder Registrybereiche getätigt.

Gruß Werner

Bernd Reinhardt
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 138
Registriert: So, 16. Apr 2006 11:12
Wohnort: Öhringen

Re: Probleme bei der Installation durch Benutzerprofile?

Beitrag von Bernd Reinhardt » Do, 12. Mär 2020 19:09

Hallo

Ich habe das Problem das manchmal noch Dateien als Dienst hängen bleiben. Das Programm ist geschlossen aber z. B. heute konnte ich die neue
xppnat.dll erst nach einem Neustart vom Rechner löschen und somit dann auch ersetzen.
Die Version 1.9 gelöscht und die 2.0 kopiert.
Vielleicht ist das auch so ein Fall das beim kopieren eine Datei noch gesperrt ist und somit nicht ersetzt werden kann.
Hatte auch mal den Effekt das mein Programm plötzlich noch im Dienste beim Admin auftauchte, obwohl ich nur lokal unter einem normalen Benutzer arbeite. Damit waren auch Dateien gesperrt.
Und seit kurzem habe ich das auch mit Access.

Falls das Programm aber auf Dateien in einem alten Ordner zugreift so kann es sein das die Umgebungsvariablen (wenn das Programm z. B. mit Adminrechten läuft) anderst sind als man beim user sieht.

Gruß
Bernd
Bernd Reinhardt
fa.reinhardt@gmx.de

Antworten