Das Forentreffen 2018 findet am 20./21. April in Dresden statt. Weitere Infos hier
Zur Homepage des Deutschsprachige Xbase-Entwickler e. V.
Xbase++-Wiki des Deutschsprachige Xbase-Entwickler e. V.

Registry Settings für XBase auf Windows 7 und Server 2008R2

Von der Installation bis zur Auslieferung der Applikation

Moderator: Moderatoren

Antworten
IngoM
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Di, 09. Jul 2013 9:23

Registry Settings für XBase auf Windows 7 und Server 2008R2

Beitrag von IngoM » Do, 06. Nov 2014 9:14

Hallo,

ich habe hier im Forum einige Beiträge, teilweise für andere Client/Server-Konfigurationen gelesen.
Mein Anspruch ist es, dass meine Programme möglichst stabil und fehlerfrei laufen; vermeintliche Performance bringt meiner Meinung nach nichts, wenn man damit schneller Fehler bekommt. Microsoft hat uns dabei schon einige Fallstricke eingebaut.

Folgende Settings spielen dabei eine Rolle:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters]
"Autodisconnect"=dword:ffffffff
"CachedOpenLimit"=dword:00000000
"ConnectionNoSessionTimeout"=dword:ffffffff
"EnableForcedLogoff"=dword:00000001
"EnableOplocks"=dword:00000000
"EnableOpLockForceClose"=dword:00000001
"OplocksDisabled"=dword:00000001
"SharingViolationDelay"=dword:00000000
"SharingViolationRetries"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
"CachedOpenLimit"=dword:00000000
"DirectoryCacheLifetime"=dword:00000000
"DisableFlushOnCleanup"=dword:00000001
"EnableOplocks"=dword:00000000
"EnableOpLockForceClose"=dword:00000001
"FileInfoCacheLifetime"=dword:00000000
"FileNotFoundCacheLifetime"=dword:00000000
"UseLockReadUnlock"=dword:00000000
"UseOpportunisticLocking"=dword:00000000
"UseUnlockBehind"=dword:00000001
"UtilizeNtCaching"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MRXSmb\Parameters]
"EnableOplocks"=dword:00000000
"OplocksDisabled"=dword:00000001

Ich habe das Registry-Format gewählt, weil es ziemlich kompakt ist.

Es wäre schön, wenn die alten Hasen hier im Forum diese Zusammenstellung mal gegenchecken könnten. Jeglicher Beitrag ist herzlich willkommen. Bitte dabei nicht zu technisch werden, damit Anfänger wie ich es noch verstehen können.
Am Ende sollen zwei .reg-Dateien herauskommen, eine für die Workstation und eine für den Server, auf dem die Datenbank (DBF/NTX) liegt.

Viele Grüße
Ingo
Viele Grüße
Ingo

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10562
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von AUGE_OHR » Fr, 07. Nov 2014 20:31

hi,

schön das du die Registry Setting zusammengestellt hast ... aber was willst du damit (erreichen) ?

wenn deine Hardware / Software "optimal" zusammengestellt wurden dann wird sich "selten" ein SMB Problem stellen da die Default Parameter dann recht gut passen für Win7/8.x - Srv2008/2012. ( XP / Srv2003 sind out )
Das gilt sowohl für Cl*pper als auch für Xbase++. ( wenn das Cl*pper Programm vorher Probleme hatte wird das nicht durch Xbase++ behoben )

Das Registry Einträge "gefährlich" sein können ist wohl klar aber wenn man in die Registry eingreift dann sollte man es "behutsam" machen und "einzelne" Einträge vornehmen und dann, über die Zeit, kontrollieren ob es Nebeneffekte gibt !!!
speziell die M$ Produkte "verlangen" nach SMB2/3 da sonst ein gemeinsames arbeiten, in Office Dokumenten, Probleme macht.

es gibt also KEIN allgemeines Rezept sondern du sollte die Probleme mit deinem Netzwerk Administrator einzeln absprechen.
gruss by OHR
Jimmy

IngoM
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Di, 09. Jul 2013 9:23

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von IngoM » Fr, 07. Nov 2014 20:46

Hallo Jimmy,

meine Idee war, die Standard-Einträge zusammenzustellen, die XBase / Clipper in der genannten Umgebung braucht.
Server und Clients sind Out-Of-The-Box nach einer Standard-Installation. Mein Kunde hat nur ein paar Arbeitsplätze, da gibt es keinen Netzwerkadministrator. Ich muss mir also alles selbst zusammensuchen.
Speziell einer Deiner Beiträge hat mir viele Infos geliefert, andere habe ich im Internet gefunden.

Ich könnte mir vorstellen, dass es auch andere Programmierer gibt, die sich wie ich nicht so gut in den Tiefen der Betriebssysteme auskennen.

Viele Grüße
Ingo
Viele Grüße
Ingo

Benutzeravatar
Jan
Foren-Administrator
Foren-Administrator
Beiträge: 12288
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Jan » Fr, 07. Nov 2014 21:19

Es gibt ein kostenloses Tool von Alaska, das genau die erforderlichen Enistellungen vornimmt. Du kannst auch Alaska fragen, ob die Dir den Code zur Verfügung stellen, damit Du den in Deine eigene App einbinden kannst.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10562
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von AUGE_OHR » Fr, 07. Nov 2014 21:21

IngoM hat geschrieben:meine Idee war, die Standard-Einträge zusammenzustellen, die XBase / Clipper in der genannten Umgebung braucht.
es gibt kein Medizin um nicht krank zu werden ... nur Empfehlungen des Doktor wie man wieder gesund wird ;)
IngoM hat geschrieben:Server und Clients sind Out-Of-The-Box nach einer Standard-Installation.
Mein Kunde hat nur ein paar Arbeitsplätze, da gibt es keinen Netzwerkadministrator. Ich muss mir also alles selbst zusammensuchen.
Speziell einer Deiner Beiträge hat mir viele Infos geliefert, andere habe ich im Internet gefunden.
solange der Patient nicht krank ist würde ich ihm keine "Operation" empfehlen ... wie soll man eine Diagnose stellen wenn man keine Symptome hat ?

Ja es gibt Empfehlungen bei bestimmten Symptomen die auch Alaska empfiehlt aber es hängt ja auch von den verwendeten Hard-/Software ab ob es die "richtige" Medizin dafür ist. es gibt allerdings auch Fälle wo es "hoffnungslos" für den Patienten aussieht z.b. wenn er noch Windows XP verwendet ...

Die SMB Problem tauchen "öfter" bei unterschiedlicher Hardware und/oder OS() Versionen auf.
die NAS Geräte die ich kennen haben meistens NICHT SMB2. Ein NAS was SMB2/3 kann kostet IMHO so viel wie ein kleiner Srv-2008.
IngoM hat geschrieben:Ich könnte mir vorstellen, dass es auch andere Programmierer gibt, die sich wie ich nicht so gut in den Tiefen der Betriebssysteme auskennen.
wie schon gesagt Eingriffe in die Registry, welche Administrator Rechte benötigen, sollte man keinem User überlassen.
Ich habe deshalb mein OpLock Tool zurück gezogen weil es eben nicht universell anwendbar ist.
gruss by OHR
Jimmy

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10562
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von AUGE_OHR » Fr, 07. Nov 2014 21:28

Jan hat geschrieben:Es gibt ein kostenloses Tool von Alaska, das genau die erforderlichen Enistellungen vornimmt. Du kannst auch Alaska fragen, ob die Dir den Code zur Verfügung stellen, damit Du den in Deine eigene App einbinden kannst.
Den Code bzw Registry Einträge hat Ingo ja schon ...

Code: Alles auswählen

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanworkstation\Parameters
DirectoryCacheLifetime
FileInfoCacheLifetime
FileNotFoundCacheLifetime
nachzulesen unter http://technet.microsoft.com/en-us/libr ... 10%29.aspx
aber man sollte schon wissen "warum" man den in "welcher" Situation anwenden soll da es sich auf "alle" Applikationen auswirkt.
gruss by OHR
Jimmy

Benutzeravatar
Roland Gentner
1000 working lines a day
1000 working lines a day
Beiträge: 857
Registriert: Fr, 24. Nov 2006 8:30
Wohnort: Neresheim
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Roland Gentner » Fr, 07. Nov 2014 21:42

Hallo Ingo

im "Normalfall" hat Jimmy Recht - mit den Standard-Einstellungen "sollte" alles gut laufen.
Aber kann es sein, dass Du irgendwo Probleme hast mit den Windows 7 Client-PCs und dem 2008er Server?
Gruß
Roland

IngoM
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Di, 09. Jul 2013 9:23

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von IngoM » Sa, 08. Nov 2014 7:59

Hallo,

die "OpLock"-EInträge stammen noch aus meiner Cl*pper-Zeit. Für DBF und NTX-Files sollten sie also weiterhin Gültigkeit haben.

@ Jan
Kannst Du mir weitere Infos über das Tool geben? Ich habe davon nichts gewußt.
Wie heißt es und wo kann ich es herunterladen.

Viele Grüße
Ingo
Viele Grüße
Ingo

Benutzeravatar
Herbert
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1822
Registriert: Do, 14. Aug 2008 0:22
Wohnort: Gmunden am Traunsee, Österreich
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Herbert » Sa, 08. Nov 2014 8:17

Ingo, es gibt einige Einträge hier im Forum
Suche nach "SMB2" oder "Patch"
z.B.
http://www.xbaseforum.de/viewtopic.php? ... smb#p83762
http://www.xbaseforum.de/viewtopic.php? ... mb2#p81188
http://www.xbaseforum.de/viewtopic.php? ... mb2#p74958
http://www.xbaseforum.de/viewtopic.php? ... hilit=smb2
Jimmy ist ganz moderat geworden betreffend Registry. Absolut richtig, was er sagt.

Dazu kommt, dass auch MS mit den eigenen Updates Veränderungen produziert und daher einige Einstellungen nicht mehr notwendig werden oder bereits (wieder) korrekt oder (wieder) falsch sind...
Grüsse Herbert
Immer in Bewegung...

Benutzeravatar
Roland Gentner
1000 working lines a day
1000 working lines a day
Beiträge: 857
Registriert: Fr, 24. Nov 2006 8:30
Wohnort: Neresheim
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Roland Gentner » Sa, 08. Nov 2014 12:22

Hier die SMB2 Cache Configuration Seite von Alaska Software:
http://www.alaska-software.com/smb2
Das Tool korrigiert drei Registry-Werte. Kannst das aber auch von Hand machen.
Habe das auch in den letzten Tagen wieder bei einem Kunden gebraucht und mir den Link (wieder) von Hr. Herdt (Alaska) geben lassen...
Gruß
Roland

Benutzeravatar
Werner_Bayern
Programmier-Gott
Programmier-Gott
Beiträge: 1288
Registriert: Sa, 30. Jan 2010 22:58
Wohnort: Niederbayern

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Werner_Bayern » Sa, 08. Nov 2014 13:04

:scratch:

Client:

Alaska setzt
This package creates and modifies values under following registry key:

HKEY_LOCAL_MACHINE\system\CurrentControlSet\Services\LanmanWorkstation\Parameters

The following registry values are created and set to zero:

FileInfoCacheLifetime
FileNotFoundCacheLifetime
DirectoryCacheLifetime
Bisher mache ich jedoch:
System\CurrentControlSet\Services\MRXSmb\Parameters:
- "OplocksDisabled" 1
- "InfoCacheLevel", 10
System\CurrentControlSet\Services\Lanmanworkstation\Parameters:
- "DisableFlushOnCleanup", 1
- "UseOpportunisticLocking", 0
und sonst nichts...

Was ist jetzt korrekt bei Problemen mit Server 2003/2008 und Clients mit Vista, Win7, Win8 in Verbindung mit 8999 oder Fehler bei DbCloseArea() etc.?
es grüßt euch

Werner

Benutzeravatar
Roland Gentner
1000 working lines a day
1000 working lines a day
Beiträge: 857
Registriert: Fr, 24. Nov 2006 8:30
Wohnort: Neresheim
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Roland Gentner » Sa, 08. Nov 2014 13:38

Hallo Werner,

die Einstellungen von Alaska helfen (meistens?) bei Win 7 und 2008.
Mit den älteren Server-OS (2003) kommt das keinesfalls vor und hilft auch nicht wenn dort Fehler passieren. Die Server haben kein SMB2.

Bei Xbase++ mit Win 7 und 2008 hat das damit zu, dass wenn Du z.B. temporäre Dateien auf einem Netzwerklaufwerk erstellst und sofort drauf zugreifst kann er vorkommen, dass Xbase++ die Datei noch nicht sieht. Die Reg-Einträge beheben das Problem.
Gruß
Roland

IngoM
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Di, 09. Jul 2013 9:23

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von IngoM » Sa, 08. Nov 2014 19:54

Hallo zusammen,

meine Suche im Umfeld SMB* fing an, als zeitgleich mit der Umstellung von Windows 7 mit SBS2003 auf Windows 7 mit SBS2011 das Drucken auf Nadeldrucker an LPTx nicht mehr funktionierte.
Im Endeffekt habe ich dieses Problem durch Umstellung auf Netzwerkdrucker umgangen.

Viele Grüße
Ingo
Viele Grüße
Ingo

Benutzeravatar
Roland Gentner
1000 working lines a day
1000 working lines a day
Beiträge: 857
Registriert: Fr, 24. Nov 2006 8:30
Wohnort: Neresheim
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Roland Gentner » Sa, 08. Nov 2014 20:53

Hallo Ingo
IngoM hat geschrieben:das Drucken auf Nadeldrucker an LPTx nicht mehr funktionierte
Das kann aber eigentlich nichts mit der Serverumstellung zu tun haben sondern eher mit dem dass Dein Kunde vielleicht Zeitgleich von XP auf Win 7 umgestellt hat?

Ist aber nicht so wichtig - Hauptsache Du hast den Fehler gefunden...
Gruß
Roland

IngoM
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Di, 09. Jul 2013 9:23

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von IngoM » Sa, 08. Nov 2014 21:41

Hallo Roland,

Windows Small Business Server 2003 ist XP-Style; dadurch wurde zwischen den Windows 7-PCs und dem Server SBS 1 gesprochen.
Zwischen Windows 7 und SBS 2011 (Windows Server 2008 R2) wurde dann SMB 2 aktiv.

Viele Grüße
Ingo
Viele Grüße
Ingo

Benutzeravatar
Roland Gentner
1000 working lines a day
1000 working lines a day
Beiträge: 857
Registriert: Fr, 24. Nov 2006 8:30
Wohnort: Neresheim
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Roland Gentner » Sa, 08. Nov 2014 22:39

Hallo Ingo

vermutlich hast Du nach der Umstellung auf 2008 mehrere Probleme - das schließe ich aus Deinen Beiträgen. Trotzdem getrennt betrachten:
1) SMB2-Problem mit Xbase++-Programmen -> Alaska-Tool
2) LPTx-Problem -> LPTx umleiten (hast Du schon erledigt)
(3) Explorer-Probleme?)

Weitere Probleme...?
Gruß
Roland

IngoM
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Di, 09. Jul 2013 9:23

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von IngoM » So, 09. Nov 2014 9:12

Hallo Roland,

natürlich sind das verschiedene Probleme.
Nach meinen Änderungen läuft jetzt aber alles.

Viele Grüße
Ingo
Viele Grüße
Ingo

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10562
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von AUGE_OHR » So, 09. Nov 2014 20:34

Roland Gentner hat geschrieben:Bei Xbase++ mit Win 7 und 2008 hat das damit zu, dass wenn Du z.B. temporäre Dateien auf einem Netzwerklaufwerk erstellst und sofort drauf zugreifst kann er vorkommen, dass Xbase++ die Datei noch nicht sieht. Die Reg-Einträge beheben das Problem.
DANKE das du erklärst hast "wofür" der Patch gedacht ist !
nun müsste man nur noch den nächsten Schritt gehen und sich überlegen "warum" es mit Xbase++ passiert und nicht mit Cl*pper und dem "selben" Code ...
gruss by OHR
Jimmy

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10562
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von AUGE_OHR » So, 09. Nov 2014 20:36

IngoM hat geschrieben:meine Suche im Umfeld SMB* fing an, als zeitgleich mit der Umstellung von Windows 7 mit SBS2003 auf Windows 7 mit SBS2011 das Drucken auf Nadeldrucker an LPTx nicht mehr funktionierte.
SMB heist nicht nur Files sondern auch Drucker, Modem, Fax usw ... also alles was man "share" kann.
IngoM hat geschrieben:Im Endeffekt habe ich dieses Problem durch Umstellung auf Netzwerkdrucker umgangen.
DAS ist die richtige Lösung !
gruss by OHR
Jimmy

Benutzeravatar
Roland Gentner
1000 working lines a day
1000 working lines a day
Beiträge: 857
Registriert: Fr, 24. Nov 2006 8:30
Wohnort: Neresheim
Kontaktdaten:

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von Roland Gentner » So, 09. Nov 2014 20:54

Hallo Jimmy

das Problem hat nicht nur Xbase++ sondern Windows selbst z.B. im Explorer. Was mich das in den letzten Jahren Nerven gekostet hat dem Problem auf den Grund zu gehen!

( http://www.xbaseforum.de/viewtopic.php?f=16&t=8248 )
Gruß
Roland

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10562
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Registry Settings für XBase auf Windows 7 und Server 200

Beitrag von AUGE_OHR » So, 09. Nov 2014 21:17

Roland Gentner hat geschrieben:( http://www.xbaseforum.de/viewtopic.php?f=16&t=8248 )
siehe meine Antwort.
gruss by OHR
Jimmy

Antworten