XbpCrt mit "clipper" Befehlen funktioniert nicht

Auf dem Weg von Clipper, FoxPro u.ä. nach Xbase++

Moderator: Moderatoren

Lutz Rübe
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 127
Registriert: Mi, 02. Aug 2006 18:13
Wohnort: 24536 Neumünster
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: XbpCrt mit "clipper" Befehlen funktioniert nicht

Beitrag von Lutz Rübe » Mo, 08. Jun 2020 21:04

Hallo alle Zusammen,
noch einmal Danke für euren Einsatz. Er hat mir mehr gebracht als ich erhofft hatte.
@Frank, dein Hinweis mit dem fehlenden SetAppWindow( oCrt ) war der Entscheidende. ich hatte vorher Crt-Fenster mit xClass erstellt und genutzt und da wurde diese Funktion nicht benötigt.
Hintergrund war tatsächlich der Gedanke, dass ich mit der MDI-Anwendung mehrere Crt-Fenster nebeneinander verwenden wollte. Der Wunsch ist zwar noch weiterhin da, aber die Umsetzung werde ich aufgrund der von euch genannten Probleme (welches Crt schreibt was wohin) vorerst etwas hintenanstellen und mich mehr auf die GUI konzentrieren.

Nach der Einbindung der SetAppWindow( oCrt ) bin ich noch auf weitere Probleme gestossen. Es hat etwas gedauert bis ich herausgefunden habe, dass die IDE mir beim Kompilieren nicht mehr alle fehlenden Funktionen (Funktion oder Prozedur fehlt) anzeigt, sondern einfach fertig kompiliert. Erst bei der Ausführung wird dann die fehlende UDF bemerkt und es kommt zu Abbrüchen.

Ich hatte nicht mitbekommen, dass ihr noch weiter über mein Problem diskutiert habt. Nochmals vielen Dank.

Gruß
Lutz

Antworten