Hinweise zum neuen Forum
Zur Homepage des Deutschsprachige Xbase-Entwickler e. V.
Xbase++-Wiki des Deutschsprachige Xbase-Entwickler e. V.

XBase++: Fehler bei "Hello World"

Auf dem Weg von Clipper, FoxPro u.ä. nach Xbase++

Moderator: Moderatoren

Antworten
Benutzeravatar
satmax
1000 working lines a day
1000 working lines a day
Beiträge: 776
Registriert: Do, 02. Dez 2010 20:34
Wohnort: Biberbach in Österreich
Kontaktdaten:

XBase++: Fehler bei "Hello World"

Beitrag von satmax » Mi, 18. Sep 2013 10:35

Fängt ja gut an... :(

Nach der Installation der XBase++ V1.9 Demo wolte ich "Ihr Einstig in nur 3 Stunden" abarbeiten, bereitsa bein ersten VIerzeiler kommt das Problem:

Beispiel: hello.prg
PROCEDURE Main
CLS
? ”Hello World”
RETURN

xpp hello liefert:
d:\DEV\DevSrc\DevAlaska>xpp hello

Xbase++ (R) Compiler 1.90.355 Apr 10 2009
Copyright (c) Alaska Software. All rights reserved.
File: hello.prg Line: 6
hello.prg(3:0): warning XBT0106: Procedure Main does not end with RETURN
hello.prg(4:0): error XBT0200: Syntax Error
1 error(s) found in file hello.prg!


Wie gesagt, diese 4 Zeilen sind aus dem beiligenden Schnelleinstig entnommen.
Gruß
Markus

Benutzeravatar
satmax
1000 working lines a day
1000 working lines a day
Beiträge: 776
Registriert: Do, 02. Dez 2010 20:34
Wohnort: Biberbach in Österreich
Kontaktdaten:

Re: XBase++: Fehler bei "Hello World"

Beitrag von satmax » Mi, 18. Sep 2013 10:38

Sorry, mein Fehler. Hatte die Datei der Einfachheit halber mit notepad erstellt. Da waren dann anscheinend Steuerzeichen enthalten. Habe eine neue Date mit Multi-Edit erstellt, jetzt passt es.
Gruß
Markus

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 13588
Registriert: Mo, 23. Jan 2006 21:54
Wohnort: Germersheim
Kontaktdaten:

Re: XBase++: Fehler bei "Hello World"

Beitrag von brandelh » Mi, 18. Sep 2013 10:45

Code: Alles auswählen

? ”Hello World”
? "Hello World"
schau dir mal die Anführungszeichen an, vermutlich typografische ... Notepad geht schon, wenn man sich quälen will ;-)
Gruß
Hubert

Benutzeravatar
satmax
1000 working lines a day
1000 working lines a day
Beiträge: 776
Registriert: Do, 02. Dez 2010 20:34
Wohnort: Biberbach in Österreich
Kontaktdaten:

Re: XBase++: Fehler bei "Hello World"

Beitrag von satmax » Mi, 18. Sep 2013 10:50

ja, das war es. Habe es via Zwischenablage aus dem PDF kopiert,

Normal verwende ich Multi-Edit.
Gruß
Markus

Benutzeravatar
satmax
1000 working lines a day
1000 working lines a day
Beiträge: 776
Registriert: Do, 02. Dez 2010 20:34
Wohnort: Biberbach in Österreich
Kontaktdaten:

Re: XBase++: Fehler bei "Hello World"

Beitrag von satmax » Mi, 18. Sep 2013 11:08

Nächsten Problem (Runtime Fehler: Parameter hat falschen Typ):

Code: Alles auswählen

#INCLUDE "Gra.ch"

PROCEDURE Main
LOCAL cVar1 := "Hello"
LOCAL cVar2 := "World"

SET COLOR TO N/W,W+/B  	// Farbe einstellen
SET CURSOR ON   	// Bildschirm-Cursor anschalten
SetMouse( .T. )   	// Maus aktivieren

CLS
GraBox( NIL, {72,176}, {200,256}, GRA_FILL, 30, 30)  // Darum geht es !!!!!!!!!!!!
@ 10,10 SAY "Hallo " GET cVar1
@ 12,10 SAY "Wer ? " GET cVar2
READ

? cVar1, cVar2

RETURN
Es geht um die Zeile: GraBox( NIL, {72,176}, {200,256}, GRA_FILL, 30, 30)

Hier das Fehlerprotokoll:

Code: Alles auswählen

------------------------------------------------------------------------------
FEHLERPROTOKOLL von "d:\DEV\DevSrc\DevAlaska\maus.exe" Datum: 18.09.2013 11:03:17

Xbase++ Version     : Xbase++ (R) Version 1.90.355
Betriebssystem      : Windows 7 06.02 Build 09200
------------------------------------------------------------------------------
oError:args         :
          -> VALTYPE: U VALUE: NIL
          -> VALTYPE: A VALUE: {72, 176}
          -> VALTYPE: A VALUE: {200, 256}
          -> VALTYPE: N VALUE: 1
          -> VALTYPE: N VALUE: 30
          -> VALTYPE: N VALUE: 30
oError:canDefault   : N
oError:canRetry     : N
oError:canSubstitute: J
oError:cargo        : NIL
oError:description  : Parameter hat falschen Typ
oError:filename     : 
oError:genCode      :          2
oError:operation    : graBox
oError:osCode       :          0
oError:severity     :          2
oError:subCode      :       1025
oError:subSystem    : BASE
oError:thread       :          1
oError:tries        :          0
------------------------------------------------------------------------------
CALLSTACK:
------------------------------------------------------------------------------
Aufgerufen von MAIN(14)
Gruß
Markus

Benutzeravatar
satmax
1000 working lines a day
1000 working lines a day
Beiträge: 776
Registriert: Do, 02. Dez 2010 20:34
Wohnort: Biberbach in Österreich
Kontaktdaten:

Re: XBase++: Fehler bei "Hello World"

Beitrag von satmax » Mi, 18. Sep 2013 11:13

Wer lesen kann ist klar im Vorteil; alink maus /PM:PM
Gruß
Markus

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast