Das Forentreffen 2018 findet am 20./21. April in Dresden statt. Weitere Infos hier
Anmeldungen zum Forentreffen 2018 sind auf der Anmeldeseite möglich
Zur Homepage des Deutschsprachige Xbase-Entwickler e. V.
Xbase++-Wiki des Deutschsprachige Xbase-Entwickler e. V.

Xbase unter Windows 10 - Programm startet nicht !

Fragen rund um diverse Windows-Versionen, ihr Verhalten unter Xbase++ und den Umgang mit der API

Moderator: Moderatoren

Antworten
xbaseklaus
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 246
Registriert: Mi, 04. Jun 2014 12:01
Wohnort: FRANKEN

Xbase unter Windows 10 - Programm startet nicht !

Beitrag von xbaseklaus » Mo, 21. Sep 2015 18:24

Hallo ich habe mal versucht ein Xbase++ 1.9.331 Programm zu starten - leider ohne Erfolg !

Das Programm bricht beim Fensteraufbau mit folgender Fehlermeldung ab !

Code: Alles auswählen

Xbase++ version     : Xbase++ (R) Version 1.90.331
Operating system    : Windows  06.02 Build 09200
------------------------------------------------------------------------------
oError:args         :
          -> VALTYPE: A VALUE: {1}
          -> VALTYPE: N VALUE: 2
oError:canDefault   : N
oError:canRetry     : N
oError:canSubstitute: Y
oError:cargo        : NIL
oError:description  : Error in array index
oError:filename     : 
oError:genCode      :          4
oError:operation    : <A of 1>[<2>]
oError:osCode       :          0
oError:severity     :          2
oError:subCode      :       1012
oError:subSystem    : BASE
oError:thread       :          1
oError:tries        :          0
------------------------------------------------------------------------------
CALLSTACK:
------------------------------------------------------------------------------
Called from DC_CLRARR(125)
Called from INIT: _DCCOLORINIT(144)
unter Windows 7 habe ich keine Probleme !

kann mich jemand erleuchten !?!

Mfg Klaus

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 10738
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Xbase unter Windows 10 - Programm startet nicht !

Beitrag von AUGE_OHR » Mo, 21. Sep 2015 19:31

xbaseklaus hat geschrieben:Hallo ich habe mal versucht ein Xbase++ 1.9.331 Programm zu starten - leider ohne Erfolg !

Code: Alles auswählen

Xbase++ version     : Xbase++ (R) Version 1.90.331
Operating system    : Windows  06.02 Build 09200[/quote]das ist KEIN Windows 10 sondern v8.0 (?)
es gibt noch die v8.1.9600 sowie die 10xxxx Version
[quote="xbaseklaus"]
...
CALLSTACK:
------------------------------------------------------------------------------
Called from DC_CLRARR(125)
Called from INIT: _DCCOLORINIT(144)
unter Windows 7 habe ich keine Probleme !
das hat doch was mit Express++ zu tun ... war da nicht gerade was mit ColorInit() ...
gruss by OHR
Jimmy

xbaseklaus
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 246
Registriert: Mi, 04. Jun 2014 12:01
Wohnort: FRANKEN

Re: Xbase unter Windows 10 - Programm startet nicht !

Beitrag von xbaseklaus » Mo, 21. Sep 2015 20:28

Ok das ist die Lösung:

http://bb.donnay-software.com/donnay/vi ... f=2&t=1627

Der Fehler wird hier auch irgendwo im Forum angesprochen ! Ich denke unter: Express++

PROBLEM erledigt :-)

Mfg Klaus

xbaseklaus
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 246
Registriert: Mi, 04. Jun 2014 12:01
Wohnort: FRANKEN

Re: Xbase unter Windows 10 - Programm startet nicht !

Beitrag von xbaseklaus » Mo, 21. Sep 2015 20:42

AUGE_OHR hat geschrieben:[...

]das hat doch was mit Express++ zu tun ... war da nicht gerade was mit ColorInit() ...
DANKE für den Hinweis :-)

Antworten