Das Forentreffen 2018 findet am 20./21. April in Dresden statt. Weitere Infos hier
Zur Homepage des Deutschsprachige Xbase-Entwickler e. V.
Xbase++-Wiki des Deutschsprachige Xbase-Entwickler e. V.

W2k8 R2 IIS und CGI

Fragen rund um diverse Windows-Versionen, ihr Verhalten unter Xbase++ und den Umgang mit der API

Moderator: Moderatoren

Antworten
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 16892
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

W2k8 R2 IIS und CGI

Beitrag von Manfred » So, 01. Mai 2016 18:51

So, jetzt mal was ganz anderes.

Ich habe mir einen Windows Server 2008 R2 als Spielwiese auf einem ESXi 5.x Server installiert und wollte ein wenig probieren. Nachdem ich nun den IIS mit CGI Unterstützung angelegt habe, mußte ich feststellen, dass im Verzeichnis \inetpub\wwwroot\ nicht wie mir versprochen wurde das Verzeichnis CGI-BIN angelegt wurde bei der Installation. War das Versprechen falsch, oder habe ich was falsch gemacht?
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 13753
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: W2k8 R2 IIS und CGI

Beitrag von brandelh » Mo, 02. Mai 2016 8:17

läuft der IIS und hast du in wwwroot eine INDEX.HTM die dir angezeigt wird wenn du localhost aufrufst ?

In meinem Beispiel ist unter "wwwroot" das bei mir anders heißt, wegen Plesk und Server beim Hoster ... noch die Domain als Verzeichnis und darunter dann CGI-BIN ...

Gibt es eine Testversion von dem Server die man mal installieren könnte ?
Was steht im Servermanager zu CGI ... ?
Gruß
Hubert

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 16892
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: W2k8 R2 IIS und CGI

Beitrag von Manfred » Mo, 02. Mai 2016 9:04

Ja, der läuft. wwwroot wird auch entfernt, wenn der IIS deinstalliert wird, und wieder angelegt, wenn der IIS installiert wird. In dem verzeichnis stehen dann eine iistart.htm und eine welcome.png. Wenn ich die Adresse des Servers im Browser aufrufe, dann wird auch die runde Grafik angezeigt. Aber mehr passiert dann nicht mehr. OK, wenn ich da reinklicke lande ich dann bei M$
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.

Benutzeravatar
Armin
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 365
Registriert: Mo, 26. Sep 2005 12:09
Wohnort: 75331 Engelsbrand
Kontaktdaten:

Re: W2k8 R2 IIS und CGI

Beitrag von Armin » Mo, 02. Mai 2016 10:23

Hallo Manfred,

das cgi-bin Verzeichnis ist ein virtueller Pfad. Darin liegen die Programme, die ein Anwender ja nicht sehen, bzw. verwalten soll.
inetpub\wwwroot\ist das documentroot-Verzeichnis das der Anwender z.B. sehen kann, wenn er im Browser http://localhost, bzw. http://ip, http://<url> aufruft.

Du kannst im IIS unter cgi-bin, rechte Maustaste, virtuelles Verzeichnis verwalten, erweiterte Einstellungen einen physikalischen Pfad hinzufügen (zuweisen).

Grüße, Armin

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 13753
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: W2k8 R2 IIS und CGI

Beitrag von brandelh » Mo, 02. Mai 2016 10:31

OK ich muss zugeben, dass meine einfache Antwort wohl nur auf den "fertigen" Hosteurope Server zutrifft, dort war alles (fast) fertig eingerichtet und die Verzeichnisse wurden angelegt.

Als ich eben den IIS von Win7 installiert habe, inkl. der Verwaltungssoftware, wird kein CGI-BIN Verzeichnis angelegt.
Ich könnte das wohl anlegen, aber schon der Zugriff auf die Standardseite (localhost) will nicht gelingen. (HTTP Fehler 503 ... also muss irgendwas doch schon laufen).

Sorry der ISS bleibt für mich ein Buch mit 7 Siegeln, kein Wunder dass ich Apaches Server zum lokalen Testen nehme, der ist einfacher einzurichten ;-)
Gruß
Hubert

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 16892
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: W2k8 R2 IIS und CGI

Beitrag von Manfred » Mo, 02. Mai 2016 10:48

@Armin,

Danke, also doch von Hand anlegen und dann entsprechende Rechte evtl. vergeben. Habe ich gemacht, Pfad ist da. Mal sehen wie ich jetzt weiter kommen.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.

Antworten