Das Forentreffen 2018 findet am 20./21. April in Dresden statt. Weitere Infos hier
Zur Homepage des Deutschsprachige Xbase-Entwickler e. V.
Xbase++-Wiki des Deutschsprachige Xbase-Entwickler e. V.

evolve in MultiEdit aktivieren, xBase-Hilfe in MultiEdit

Alles rund um Editoren, visuelle Entwicklungshilfen und Form-Designer

Moderator: Moderatoren

Antworten
UliTs
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2449
Registriert: Fr, 10. Feb 2006 9:51
Wohnort: Aachen
Kontaktdaten:

evolve in MultiEdit aktivieren, xBase-Hilfe in MultiEdit

Beitrag von UliTs » So, 23. Sep 2007 13:00

Hallo allerseits,

zunächst noch einmal vielen Dank an die XUG Osnabrück, daß ich am Usermeeting in Osnabrück teilnehmen durfte. Es war doch sehr interessant.

Hallo Andreas,
unter MultiEdit kann man die xBase-Hilfe wie folgt einbinden:
  • a) eine PRG-Datei öffnen
    b) Klick auf die rechte Maustaste
    c) Menüpunkt "customize this file settings" und "Extension Setup"
    c) Feld Default Help File auf "c:\alaska\xppw32\book\xppref.hlp" bei Standardinstallation von xBase setzen
Dann kann man mit Strg-F1 direkt die Alaska-Hilfe aufrufen.

Jetzt zu meinem akuten Problem:
Andreas, beim user Meeting hattest Du mir geholfen, die "evolve"-Erweiterung einzubinden. Leider war sie am nächsten Tag wieder aus MultiEdit "verschwunden".

Ich sehe zwar unter Tools/Customize/General, Button Toolbars/Boxes, Evolve editieren, daß Evolve installiert und aktiviert ist (Schalter Hidden NICHT angeklickt), aber die Schalterleiste erscheint einfach nicht. Es gelingt mir nicht, den Quellcode automatisch zu formatieren.
Wie kann ich die Schalterleiste zum Leben erwecken oder auf anderem Weg Quellcode automatisch formatieren?

Uli

Benutzeravatar
andreas
Foren-Moderator
Foren-Moderator
Beiträge: 1638
Registriert: Mi, 28. Sep 2005 10:53
Wohnort: Osnabrück
Kontaktdaten:

Re: evolve in MultiEdit aktivieren, xBase-Hilfe in MultiEdit

Beitrag von andreas » Mo, 24. Sep 2007 11:00

UliTs hat geschrieben:Hallo allerseits,

zunächst noch einmal vielen Dank an die XUG Osnabrück, daß ich am Usermeeting in Osnabrück teilnehmen durfte. Es war doch sehr interessant.

Hallo Andreas,
unter MultiEdit kann man die xBase-Hilfe wie folgt einbinden:
  • a) eine PRG-Datei öffnen
    b) Klick auf die rechte Maustaste
    c) Menüpunkt "customize this file settings" und "Extension Setup"
    c) Feld Default Help File auf "c:\alaska\xppw32\book\xppref.hlp" bei Standardinstallation von xBase setzen
Dann kann man mit Strg-F1 direkt die Alaska-Hilfe aufrufen.

Jetzt zu meinem akuten Problem:
Andreas, beim user Meeting hattest Du mir geholfen, die "evolve"-Erweiterung einzubinden. Leider war sie am nächsten Tag wieder aus MultiEdit "verschwunden".

Ich sehe zwar unter Tools/Customize/General, Button Toolbars/Boxes, Evolve editieren, daß Evolve installiert und aktiviert ist (Schalter Hidden NICHT angeklickt), aber die Schalterleiste erscheint einfach nicht. Es gelingt mir nicht, den Quellcode automatisch zu formatieren.
Wie kann ich die Schalterleiste zum Leben erwecken oder auf anderem Weg Quellcode automatisch formatieren?

Uli
Hallo Ulli,

Danke für den Hinweis, wie man die XBase-Hilfe in MultiEdit einbindet, habe aber schon die Doku dazu gefunden.

Zu Evolve.
Bei mir habe ich für PRG-Dateien unter "Edit Filename Extention Setup" unter Language CLI.CA-CLIPPER stehen. Vielleicht ist das dein Problem. Sonst habe ich glaube ich nichts mehr gemacht. Es ist schon zu lange her.
Unter Evolve-Configuration steht bei mir auch CA-CLIPPER.
Gruß,

Andreas
VIP der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e. V.

UliTs
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2449
Registriert: Fr, 10. Feb 2006 9:51
Wohnort: Aachen
Kontaktdaten:

Beitrag von UliTs » Mo, 24. Sep 2007 13:29

Hallo Andreas,

danke für die Hilfe.
Es ist wohl so wie Du vermutest: die evolve-Schalter werden nicht eingeblendet, weil evolve "glaubt", daß die PRG-Dateien kein xBase bzw. Clipper-Code sind. Die Umschaltung der Sprache auf CLI.CA-Clipper brachte noch nicht den erhofften Erfolg.

Wie komme ich an die evolve-Configuration ran?

Wenn ich z.B. innerhalb einer PRG-Datei die rechte Maustaste anklicke, gibt es zwar einen Eintrag "Evolve Menu", dieser ist aber leider nicht aktiviert.

Uli

Benutzeravatar
Lewi
1000 working lines a day
1000 working lines a day
Beiträge: 780
Registriert: Di, 07. Feb 2006 14:10
Wohnort: Hamburg

Beitrag von Lewi » Mo, 24. Sep 2007 17:08

Hallo Uli,
welche ME-Version nutzt Du? Auf meinen Rechnern habe ich sowohl ME 2006 als auch 9.0E installiert.

MfG
Olaf

Benutzeravatar
andreas
Foren-Moderator
Foren-Moderator
Beiträge: 1638
Registriert: Mi, 28. Sep 2005 10:53
Wohnort: Osnabrück
Kontaktdaten:

Beitrag von andreas » Mo, 24. Sep 2007 18:02

UliTs hat geschrieben:Hallo Andreas,

danke für die Hilfe.
Es ist wohl so wie Du vermutest: die evolve-Schalter werden nicht eingeblendet, weil evolve "glaubt", daß die PRG-Dateien kein xBase bzw. Clipper-Code sind. Die Umschaltung der Sprache auf CLI.CA-Clipper brachte noch nicht den erhofften Erfolg.

Wie komme ich an die evolve-Configuration ran?

Wenn ich z.B. innerhalb einer PRG-Datei die rechte Maustaste anklicke, gibt es zwar einen Eintrag "Evolve Menu", dieser ist aber leider nicht aktiviert.

Uli
Hallo Ulli,

versuch mal eine PRG-Datei zu öffnen, dann Evolve-Menu aus- und wieder einschalten.
Gruß,

Andreas
VIP der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Lewi
1000 working lines a day
1000 working lines a day
Beiträge: 780
Registriert: Di, 07. Feb 2006 14:10
Wohnort: Hamburg

Beitrag von Lewi » Mo, 24. Sep 2007 18:21

Um die Toolbar wieder sichtbar zu machen:

Öffne eine PRG-Datei


1. Aktive das Menü: "Tools/Customize"
2. Wähle unter "General" -> Toolbar/boxes...
3. Wähle aus dem Dialog "Toolboxes" den Eintrag "Evolve"
4. Aktive "Edit" und es öffnet sich ein weiterer Dialog
5. Der Eintrag "hidden" müsste bei Dir aktiviert sein. De-aktiviere ihn und schliesse die Dialoge.


Nach dem Punkt 5 sollte nun die Toolbar sichtbar sein. Gehe anschließend in das Konfigurations-Menu der Toolbox und aktiviere den Eintrag "Evolve enabled allways" unter "Enviroment".

Wenn Du für .CH-Files oder andere Dateien ebenfalls die Funktionen der Evolve-Toolbox nutzen möchtest, mußt Du unter "Extention Setup" (über die rechte Mouse-Taste) als Language "Cli.Ca-Clipper" wählen.


Viele Grüße
Olaf

UliTs
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2449
Registriert: Fr, 10. Feb 2006 9:51
Wohnort: Aachen
Kontaktdaten:

Beitrag von UliTs » Di, 25. Sep 2007 9:50

Hallo Levi und Andreas,

danke für Eure Tipps.

Wie bereits in der ersten Nachricht geschrieben ist der Schalter Hidden NICHT angeklickt. Aber auch anklicken und erneutes ausschalten führt nicht zum Erfolg.
Gehe anschließend in das Konfigurations-Menu der Toolbox und aktiviere den Eintrag "Evolve enabled allways" unter "Enviroment".
Wie ruft man denn das Konfigurations-Menü auf? Wo finde ich den Eintrag "Evolve enabled allways"?

Inzwischen habe ich mich nicht mehr Stunden sondern Tage mit der Aktivierung von Evolve rumgeschlagen. Eine einzige Katastrophe :( .
Uli

P.S. Meine Version ist 9.10.04; gibt es noch eine aktuellere?

UliTs
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2449
Registriert: Fr, 10. Feb 2006 9:51
Wohnort: Aachen
Kontaktdaten:

Beitrag von UliTs » Di, 25. Sep 2007 10:28

Es geschehen noch Zeichen und Wunder :D

Ja, ich habe es geschafft! Die Evove-Buttonleiste ist zu sehen!
Ich war zum x-ten mal im Filename Extension Setup. Zur Abwechlsung habe ich mal die Zeilennummern (line numbers) aktiviert. Nur: sie waren nicht zu sehen! :?: :idea:
:idea: :idea: :idea: Erkennt MultiEdit meine PRG-Dateien vielleicht nicht als solche an? Kann es etwa sein, daß MultiEdit nach Groß-/Kleinschrift bei den Extensions unterscheidet? Also habe ich mal

Code: Alles auswählen

PRG, CH, INI, XPJ
umerweitert.
Danach hatte ich zwar noch keine evolve-buttons aber Zeilennummern! :) Und nach einem Neustart war die Evolve-Buttonleiste da! :wav: :wav:

Was für ein Schwachsinn!

Ich muß sagen, so umfangreich die Möglichkeiten von MultiEdit sind, so enttäuscht bin ich von der Benutzerfreundlichkeit.

Vielleicht gibt es ja einen Schalter, daß MultiEdit bei Dateinamen und Extension nicht nach Großkleinschrift unterscheidet?

Uli

UliTs
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2449
Registriert: Fr, 10. Feb 2006 9:51
Wohnort: Aachen
Kontaktdaten:

Beitrag von UliTs » Di, 25. Sep 2007 11:31

Zu früh gefreut! :( :( :(
Nach Wechsel in eine andere PRG Datei oder nach Kompilieren waren die Buttons wieder verschwunden.
Aber immerhin, wenn ich anschließend die Fileextension verändere, MultiEdit beende und wieder neu starte, gelingt es mir innerhalb weniger Minuten :cry: die Buttonleiste wieder zum Leben zu erwecken.

Uli

Antworten