Das Forentreffen 2018 findet am 20./21. April in Dresden statt. Weitere Infos hier
Zur Homepage des Deutschsprachige Xbase-Entwickler e. V.
Xbase++-Wiki des Deutschsprachige Xbase-Entwickler e. V.

Verknüpfung vs. Explorer [ERLEDIGT]

Sonstiges (nicht kategorisierbar)

Moderator: Moderatoren

Antworten
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 16942
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Verknüpfung vs. Explorer [ERLEDIGT]

Beitrag von Manfred » Mo, 15. Feb 2016 15:38

Gerade habe ich mal wieder eine interessante Entdeckung gemacht.
Bei einem Kunden gibt es einen PC, der eine serielle Waage angeschlossen hat. Das Programm prüft am Anfang ob die Waage angeschlossen ist an der Schnittstelle. Jetzt habe ich festgestellt, dass diese Prüfung nur zum Erfolg führt, wenn das Programm über die Desktopverknüpfung aufgerufen wird. Wird das Programm direkt über den Explorer aufgerufen, wird keine Waage gefunden. Der PC hat Win7 drauf und läuft in einer Domäne. Kann das mit irgendwelchen Gruppenrichtlinien zu tun haben? Alles sehr verworren. :confused2:
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 13765
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: Verknüpfung vs. Explorer

Beitrag von brandelh » Mo, 15. Feb 2016 15:50

Ich hatte mal festgestellt, dass das aktive Verzeichnis unterschiedlich (sein kann) ist, wenn man über Verknüpfung oder Explorer startet.
Ebenso könnte in einer Verknüpfung auch ein Parameter übergeben werden.
Gruß
Hubert

Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 6797
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Kontaktdaten:

Re: Verknüpfung vs. Explorer

Beitrag von Tom » Mo, 15. Feb 2016 15:52

Der direkteste Unterschied mag darin bestehen, dass beim Exploreraufruf möglicherweise in einem anderen Arbeitsverzeichnis gewurschtelt wird, während in der Verknüpfung eines zugewiesen ist. Ergo könnte es so sein, dass erwartete Dateien (INI oder ähnliches) nicht gefunden werden und falsch defaulten. Wenn man den Explorer aus Sicht eines anderen als der des angemeldeten Benutzers aufruft, mag es noch komplizierter werden. Das ging (direkt) aber zuletzt mit Windows XP, danach meines Wissens nicht mehr.
Herzlich,
Tom

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2284
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Verknüpfung vs. Explorer

Beitrag von Wolfgang Ciriack » Mo, 15. Feb 2016 16:11

Laß dir doch mal zur Prüfung vor dem Testen der Waage, Com, Baud, Parität etc. anzeigen.
Viele Grüße
Wolfgang

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 16942
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Verknüpfung vs. Explorer

Beitrag von Manfred » Mo, 15. Feb 2016 16:49

ich habe mir Meldepunkte eingerichtet Schritt für Schritt. Es scheint wohl ein Zufall gewesen zu sein, das es mal so klappt und anders wieder nicht. So wie es jetzt aussieht liegt er Fehler wohl woanders. Die COm Anfrage klappt. Aber wenn das Programm Werte von der Waage abfragt, da liegt wohl irgendein Denkfehler vor. Das wird noch lustig heute....
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 16942
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Verknüpfung vs. Explorer

Beitrag von Manfred » Mo, 15. Feb 2016 17:37

Problem behoben. Das war vielleicht ein Murks. Aber nichts, was hier erwähnenswert wäre. Einfach nur jede Menge Mist auf einen Haufen und das alles quer durcheinander.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.

Antworten