Das nächste Entwicklertreffen findet Anfang Mai in Münster statt - weitere Infos bzw. zur Anmeldung!

Performance mit Windows Server 2016

Sonstiges (nicht kategorisierbar)

Moderator: Moderatoren

Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2091
Registriert: Fr, 23. Dez 2005 8:00
Wohnort: Aalen
Kontaktdaten:

Re: Performance mit Windows Server 2016

Beitrag von Koverhage » Fr, 03. Feb 2017 7:44

Jimmy,
Kannst Du das belegen ?

hast du beim Kunden ein Problem oder wir ?
Ich habe die Probleme nicht wirklich, sondern der Kunde. Außerdem solltest Du besser lesen:
Das kannst Du das belegen bezieht ich ausschließlich auf Huberts Aussage
Auf jeden Fall ist es hilfreich, die Netz-Laufwerke nicht einem Laufwerksbuchstaben zuzuordnen sondern die Dateien mit UNC zu öffnen.
UNC Path Zugriff hat man nur auf freigegebene Ordner !!!
Mit Verlaub, das ist Bullshit. Wenn Du den Beitrag richtig gelesen hättest, die Anwendung hat von überall Zugriff
auf die Daten, nur nicht in dem IMGVIEW Sample von Alaska.
Gruß
Klaus

Benutzeravatar
HaPe
Foren-Moderator
Foren-Moderator
Beiträge: 562
Registriert: So, 15. Nov 2015 17:44
Wohnort: 71665 Vaihingen-Enz

Re: Performance mit Windows Server 2016

Beitrag von HaPe » Fr, 03. Feb 2017 10:41

Hallo Jimmy !
könntest du es bitte auch mal mit einer Xbase++ App versuchen ... und wenn du hast mit DBU.EXE oder einer anderen Cl*pper App als Vergleich.
Mit meinem ersten Xbase-Tool kommt das raus:
Verbindung per UNC:
- USE => 140 Pakete mit 199804 Bytes
Notebook neu gestartet
Verbindung per LW-Buchstaben:
- USE => 152 Pakete mit 218639 Bytes
Protokoll war SMBOverTCP, dazwischen Pakete mit SMB:2 R READ
Start-Port 445 Microsoft-DS SMB-Freigaben, Ziel-Port 58777

- BROWSE bis Datensatz 1000 in der Konsole mit 24 Datensätzen in der Anzeige => 297 Pakete mit 425360 Bytes, dabei hat ein Datensätz eine Länge von 452 Bytes.
--
Hans-Peter

Organisator der XUG Stuttgart
Beisitzer des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Performance mit Windows Server 2016

Beitrag von AUGE_OHR » Fr, 03. Feb 2017 21:17

hi Klaus,
Koverhage hat geschrieben:
UNC Path Zugriff hat man nur auf freigegebene Ordner !!!
Mit Verlaub, das ist Bullshit. Wenn Du den Beitrag richtig gelesen hättest, die Anwendung hat von überall Zugriff auf die Daten, nur nicht in dem IMGVIEW Sample von Alaska.
bitte wirf jetzt nicht alles durch einander und sage genau was dein Kunde für Probleme hat.

das Thema SMB handelt ja von gemeinsamer Nutzung wobei wir ja nur von DBF/Index Dateien Problemen reden.
natürlich bin ich zunächst davon ausgegangen das es sich um DBF/Index Probleme mit dem Server handelt und nicht um "andere" Problem wie Android und Bilder mit Imageview.

das man per UNC Path nur "freigegebene Ordner" erreichen kannst ist war nur ein Hinweis.

das Imageview umgeschrieben werden muss für UNC Path ist ja wohl klar denn ein CURDIRVE()
ist eben nicht mehr "erlaubt" wenn es um (modernes) Netzwerk geht.

p.s. das einfachste wäre die Combobox für die "Laufwerke" zu ersetzten mit erlaubten Server UNC Path
gruss by OHR
Jimmy

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Performance mit Windows Server 2016

Beitrag von AUGE_OHR » Fr, 03. Feb 2017 21:20

HaPe hat geschrieben:Mit meinem ersten Xbase-Tool kommt das raus:
Danke für deine Bemühung.
Frage : sind die Dateien vergleichbar gross ?

ich frage deshalb weil sich die Anzahl doch stark unterscheidet, oder ?
gruss by OHR
Jimmy

Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2091
Registriert: Fr, 23. Dez 2005 8:00
Wohnort: Aalen
Kontaktdaten:

Re: Performance mit Windows Server 2016

Beitrag von Koverhage » Sa, 04. Feb 2017 9:38

das man per UNC Path nur "freigegebene Ordner" erreichen kannst ist war nur ein Hinweis.
Ja eben Bullshit, Wie soll ich auf einen Server zugreifen wenn die entsprechenden Ordner nicht freigegeben sind ?
Jimmy, lies bitte richtig, werde in diese Thread nicht mehr auf Deine Beiträge antworten.
Gruß
Klaus

Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2091
Registriert: Fr, 23. Dez 2005 8:00
Wohnort: Aalen
Kontaktdaten:

Re: Performance mit Windows Server 2016

Beitrag von Koverhage » Sa, 04. Feb 2017 9:40

Falls es interessiert, Server 2016, Clients alle WIN 10
Gruß
Klaus

Benutzeravatar
HaPe
Foren-Moderator
Foren-Moderator
Beiträge: 562
Registriert: So, 15. Nov 2015 17:44
Wohnort: 71665 Vaihingen-Enz

Re: Performance mit Windows Server 2016

Beitrag von HaPe » Sa, 04. Feb 2017 10:41

Hallo Jimmy !
Mit meinem ersten Xbase-Tool kommt das raus:
Danke für deine Bemühung.
Frage : sind die Dateien vergleichbar gross ?
ich frage deshalb weil sich die Anzahl doch stark unterscheidet, oder ?
Die Tests liefen auf die gleiche Tabelle mit 150 MB mit neu gestarten Maschinen.
--
Hans-Peter

Organisator der XUG Stuttgart
Beisitzer des Deutschsprachige Xbase-Entwickler e. V.

DelUser01

Re: Performance mit Windows Server 2016

Beitrag von DelUser01 » Sa, 04. Feb 2017 12:05

Hallo Klaus
Koverhage hat geschrieben:Falls es interessiert, Server 2016, Clients alle WIN 10
Da sollten eigentlich Betriebssystemseitig alle Netzwerkkomponenten sauber und schnell zusammenarbeiten.

Durchsatzproblemen können aber noch viele weitere Faktoren verursachen.
Treiber für Netzwerkkarten, Switch, Verkabelung...
Entweder es ist etwas ganz Banales was das Problem verursacht (z.B. viel zu billige Hardware gekauft, grundlegende Fehler bei der Betriebssystem-Installation, Hyper-V falsch konfiguriert) - oder es wird nicht einfach die Ursache einzukreisen.
Ist Dein Programm auf allen Client-PCs im Netz gleich langsam? Alter PC, neuer PC, anderer Zugang im Netz (direkt am Server) usw.
Wie habt Ihr herausgefunden dass es "nur" Deine Applikation betrifft? Vergleiche mit anderen Servern im Netz möglich?

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Performance mit Windows Server 2016

Beitrag von AUGE_OHR » So, 05. Feb 2017 3:50

Koverhage hat geschrieben:Wie soll ich auf einen Server zugreifen wenn die entsprechenden Ordner nicht freigegeben sind ?
wenn ein User kein Recht hat darf er auf einem Server auch nicht "Rum-wurschteln" [-X
Wenn ein Ordner freigeben wurde und der User Mitglied ist dann bekommst man auch einen UNC Path und Zugriff.

aber unabhängig davon kommen wir nicht weiter so lange du uns nicht erzählst was für "Performance Probleme" du hast.
an der Hardware / Software OS() scheint es wohl weniger zu liegen also was macht deine App für "Performance Problem" was ja nichts mit Imageview zu hat, oder ?
gruss by OHR
Jimmy

Antworten