Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Vom Front-End bis SOAP.

Moderator: Moderatoren

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13551
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Jan » Fr, 26. Apr 2019 16:14

Hallo,

gibt es irgend eine Möglichkeit, hier eine Fehlerrückmeldung zu erhalten? Das kann doch nicht einfach nur die Rückgabe .T./.F. vom :connect() oder :send() sein. Da muß es doch mehr geben.

Jan
Zuletzt geändert von Jan am Sa, 27. Apr 2019 7:49, insgesamt 1-mal geändert.
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 7765
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand

Beitrag von Tom » Fr, 26. Apr 2019 17:10

Was willst Du denn noch wissen? Dass die Mail angekommen ist? :razz:
Herzlich,
Tom

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13551
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand

Beitrag von Jan » Fr, 26. Apr 2019 17:24

Hallo Tom,

Scherzkeks 8) Nein, natürlich nicht. Aber es gibt immerhin eine ganze Reihe von SMTP-Rückmeldungen die angeben, ob der Mailversand geklappt hat (das bekomme ich ja noch vom :send() zurück, wenn auch nicht detailliert sondern nur als .T./.F.), sondern auch die Ursachen bei Fehlern. Halt der ganze 500er-Block der SMTP-Rückmeldungen in diesem Fall.

Beim HTTPClient() geht das per :getStatusCode. Warum also sollte das nicht auch beim SMTPClient() klappen? Wenn Alaska das denn wollte?

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12126
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Rückmeldungen beim SMTPClient()-Mailversand

Beitrag von AUGE_OHR » Sa, 27. Apr 2019 2:28

Jan hat geschrieben:
Fr, 26. Apr 2019 17:24
Wenn Alaska das denn wollte?
frage Alaska doch ... :roll:

---

in DOT Net gäbe es die SmtpException Class
https://docs.microsoft.com/de-de/dotnet ... mework-4.8
aber das "spricht" Xbase++ ja nicht ...

---

wenn man bei einem API Aufruf einen Fehler bekommt kann man ihn gewöhnlich mit GetLastError() abfragen.
https://msdn.microsoft.com/en-us/librar ... s.85).aspx

Code: Alles auswählen

rc := @KERNEL32:GetLastError()
um eine "lesbare" Anzeige zu bekommen kann man diesen Code verwenden

Code: Alles auswählen

FUNCTION FormatErrorMessage( nError )               // Error as Text
LOCAL cMessage := SPACE(512)

   DEFAULT nError TO GetLastError()

   @KERNEL32:FormatMessageA( FORMAT_MESSAGE_FROM_SYSTEM,;
                   0          ,; // pointer to message source
                   nError     ,; // message ID
                   0          ,; // language ID (default)
                   @cMessage  ,; // pointer to message buffer
                   512        ,; // max size of message buffer
                   0           ) // address of array of Message inserts

   cMessage := ConvToOemCP( cMessage )

RETURN TRIM(cMessage)
gruss by OHR
Jimmy

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13551
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand

Beitrag von Jan » Sa, 27. Apr 2019 7:45

Jimmy,

keines Deiner Worte ist hilfreich, da es in keinster Weise auf SMPTClient() eingeht. Ich hatte ja nicht gefragt wie ich per .NET oder API-Aufruf eine Mail versenden kann. Sondern wie ich bei SMTPClient() eine Statusmeldung erhalten kann.

Jan
Zuletzt geändert von Jan am Sa, 27. Apr 2019 7:49, insgesamt 1-mal geändert.
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13551
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand

Beitrag von Jan » Sa, 27. Apr 2019 7:48

Interessant. Wenn man sich das oSmtp-Objekt im Debugger anschaut, dann gibt es dort ein cBuffer. Und darin steht die gewünschte Statusmeldung - sowohl als Ziffer als auch als Langtext und weiteren Details. Ich kann also nach dem oSmtp:send() einfach ein oSmtp:cBuffer machen, da steht dann alles drin. Das ist dann z. B. bei einer ungültigen Empfangsadresse:
501 Syntax error in parameters or arguments
.123.129]
250-8BITMIME
250-AUTH LOGIN PLAIN
250 SIZE 69920427
250 STARTTLS
Sollte Alaska mal in seine Doku mit rein schreiben...

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » Fr, 24. Mai 2019 9:21

Hallo Jan

hast du es geschafft die Variable cBuffer nicht nur im Debugger anzuschauen sondern auch im Programm auszuwerten?

Wenn ich auf "cBuffer" zugreifen will führt das zur Fehlermeldung "Zugriff auf Member-Variable nicht erlaubt"
Valar Morghulis

Gruss Carlo

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13551
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Jan » Fr, 24. Mai 2019 9:42

Carlo,

genau das ist das Problem. Debugger ja, sonst nicht.

Der Support hat mich dann auf die Hilfe zu SMTPClient() verwiesen. Dort ist im Sample eine Klasse LogWriter() implementiert. Damit klappt das dann.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » Fr, 24. Mai 2019 10:58

Hallo Jan

dann nehme ich auch den Logger Slot. Die Angaben in cBuffer hätten mir fürs Loggen jedoch besser zugesagt ....

Danke.
Valar Morghulis

Gruss Carlo

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13551
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Jan » Fr, 24. Mai 2019 11:03

Hallo Carlo,

so isses. Hätte mir auch besser gefallen mit dem internen cBuffer. Aber wenn Alaska das so verwurstelt macht, dann müssen wir halt damit leben. Leider.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » Fr, 24. Mai 2019 14:00

Hallo Jan

eine gute alternative war bis anhin das Tool see32.dll von Marshallsoft. Leider unterstützt dieses keine SSL Verbindungen sondern benötigt dazu stunnel.exe. Genau hier liegt nun ein neues Problem. Die Provider zwingen dich nun ultimativ zum Umstieg auf Port 465 mit SSL. Das geht mit STunnel ja auch aber nicht so ohne Probleme vorallem beim Mailen aus Threads aus einem Dienst ....

Deshalb versuche ich nun den SMTPClient zu verwenden.
Valar Morghulis

Gruss Carlo

Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 7765
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Tom » Fr, 24. Mai 2019 14:10

Marshallsoft funktioniert nicht mehr mit Xbase++ 2.0.
Herzlich,
Tom

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15042
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Martin Altmann » Fr, 24. Mai 2019 16:48

Tom,
bist du dir da sicher? Ich habe 2.0 im Einsatz (nicht die aktuelle Build) und sende Mails mit See4XB (sowohl unverschlüsselt, als auch verschlüsselt).

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Schubi
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 133
Registriert: Mi, 05. Okt 2005 15:10
Wohnort: Wiesloch

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Schubi » Fr, 24. Mai 2019 16:55

Marshallsoft funktioniert nicht mehr mit Xbase++ 2.0.
Fake News :D
Bei uns läuft es.
Grüße Steffen

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » Fr, 24. Mai 2019 18:00

Hallo Tom

da irrst du. Ich habe die aktuelle see32 8.0.2 die funktioniert mit dem xbase build 2.00.1095
Leider kann diese SSL Verbindungen jedoch nur über den Zusatz sTunnel.exe ausführen.
Diese Kombination macht mir zuviele Probleme.
Valar Morghulis

Gruss Carlo

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2558
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Wolfgang Ciriack » So, 26. Mai 2019 17:37

Hallo,
ich versende auch mit See4xb, klappt alles. Jetzt habe ich bei zwei Kunden, die über @web.de versenden, das Problem, dass angehängtes PDF-Dokument beim Empfänger nicht geöffnet werden können. Es kommt die Meldung, dass "....Datei beschädigt oder als Mailanhang geschickt und nicht korrekt dekodiert wurde."
Woran kann es liegen, dass das nur beim Versenden über web.de-Adressen passiert ?
Viele Grüße
Wolfgang

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » So, 26. Mai 2019 19:36

Hallo Wolfgang

ich versende die meisten der Mail mit einem von L&L erstellten PDF im Anhang mit see32 bis jetzt allerdings immer über einen Mail Server des Internetproviders da ist dies noch immer wenigstens noch für einige Tage über Port 25 möglich. Nun muss ich die Verbindung allerdings (zwangsmässig) auf SSL und Port 465 umstellen.......

Lass dir doch mal so Mail mit "beschädigter" PDF an dich weiterleiten und vergleiche diese mit dem Original.
Valar Morghulis

Gruss Carlo

Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 7765
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Tom » Mo, 27. Mai 2019 10:30

Mmh. Dann muss das an mir gelegen haben, jedenfalls funktionierte das nicht, und da ich bei Marshallsoft auch explizit nur Versionen für 1.9 gefunden habe, habe ich kurzerhand auf die Xbase++-Funktionalitäten umgestellt. Hätte ich also nicht machen müssen? Erstaunlich. 8)
Herzlich,
Tom

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » Mo, 27. Mai 2019 10:51

Hallo Tom

Es ist vielleicht besser dass du umgestellt hast. Zur Kommunikation mit SSL bezw. mit Mailserver Port 465 ist See32 wegen der Abhängigkeit von STUNNEL.EXE welches zwingend benutzt werden muss und den Sorgen und Probemen damit, nicht wirklich zu empfehlen!

Da ist die Lösung von Xbase++ mit SMPTClient() wesentlich einfacher zu handeln.
Valar Morghulis

Gruss Carlo

Benutzeravatar
Werner_Bayern
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1703
Registriert: Sa, 30. Jan 2010 22:58
Wohnort: Niederbayern

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Werner_Bayern » Mo, 27. Mai 2019 12:15

ramses hat geschrieben:
Mo, 27. Mai 2019 10:51
Da ist die Lösung von Xbase++ mit SMPTClient() wesentlich einfacher zu handeln.
und um Welten schneller!
es grüßt euch

Werner

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1500
Registriert: Mi, 28. Jul 2010 17:16

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von ramses » Mo, 27. Mai 2019 13:15

Richtig Werner

UND UM WELTEN SCHNELLER!!!
Valar Morghulis

Gruss Carlo

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2558
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Wolfgang Ciriack » Di, 04. Jun 2019 10:50

Mein Problem mit den Mails über web.de liegt an Anhängen mit Umlauten im Anhangsnamen :(
Viele Grüße
Wolfgang

Benutzeravatar
Werner_Bayern
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1703
Registriert: Sa, 30. Jan 2010 22:58
Wohnort: Niederbayern

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Werner_Bayern » Di, 04. Jun 2019 11:35

Servus Wolfgang,

Du hast schon

Code: Alles auswählen

oMail := MyMIMEMessage():encodeQuotedPrintable( Char2UTF8(cBody), "text/html; charset=UTF-8")
drin?

Ich kann damit einwandfrei Dateien mit Umlauten im Namen versenden.
es grüßt euch

Werner

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2558
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Wolfgang Ciriack » Di, 04. Jun 2019 20:05

Hallo Werner,
da muss ich noch mal meinen Code von See4xb durchschauen. Bisher habe ich bei keinem Kunden probleme gehabt, erst jetzt bei den beiden, die mit web.de-Mailadresse versenden. Erste Hilfe war erst einmal Ä dur Ae zu ersetzen, dann lief es.
Aber ich schau mal, wie ich das evtl. bei Marshallsoft setzen kann.
Viele Grüße
Wolfgang

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2558
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Rückmeldungen beim SMTPClient()-Mailversand [Erledigt]

Beitrag von Wolfgang Ciriack » Sa, 08. Jun 2019 10:48

Hallo Werner,
also ich bekomme das nicht hin. Versenden kann ich mit Anhang "Änderungen.pdf", kommt auch an als Mail mit richtigem Namen "Änderungen.pdf" beim Empfänger an,
wenn ich dann die PDF-Datei öffnen möchte, kommt die Meldung vom Adobe Reader: ...konnte ... nicht öffnen, da Dateityp nicht unterstüzt... oder Datei beschädigt ist (wenn sie als E-Mail-Anhang geschickt und nicht korrekt dekodiert wurde)."
Wie gesagt, nur bei Mails, die über ..@web.de verschickt werden, bei allen bisher benutzten Providern klappt es.
Viele Grüße
Wolfgang

Antworten