STunnel und See4XB

Moderator: Moderatoren

Antworten
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15542
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 7 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

STunnel und See4XB

Beitrag von Martin Altmann » Fr, 25. Sep 2020 12:35

Moin,
wer kennt sich denn mit der Konfiguration in Verbindung mit STunnel gut aus?
Bisher nutzte ich See4XB mit der mitgelieferten STunnel-Version und lokalem Aufruf (Stunnel starten, Mail senden, Stunnel stoppen). Lief.
Nun musste ich STunnel auf dem Server selber installieren und permanent laufen lassen, da ich es noch aus einem anderen Grund brauche. Also dacht ich mir, ich füge die in der SmtpConfig(0).txt stehenden Einstellungen in der stunnel.conf der Neuinstallation hinzu. Die Anpassungen im Programm für den Aufruf von XseeSetProxySSL() habe ich auch gemacht - zeige also auf die Neuinstallation von STunnel.
Allerdings scheint See4XB halt die stunnel.exe für das Versenden der Mail starten zu wollen, was nicht klappt (da es ja bereits permanent läuft). Was mache ich falsch?

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13918
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Hat sich bedankt: 4 Mal
Danksagung erhalten: 7 Mal
Kontaktdaten:

Re: STunnel und See4XB

Beitrag von Jan » Fr, 25. Sep 2020 13:23

Martin,

kannst Du nicht die Mailfunktion aus Xbase++ nutzen.? Die kann ja auch SSL/TLS.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15542
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 7 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: STunnel und See4XB

Beitrag von Martin Altmann » Fr, 25. Sep 2020 13:40

Nein, da ich keine Prof-Sub habe.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
andreas
Foren-Moderator
Foren-Moderator
Beiträge: 1843
Registriert: Mi, 28. Sep 2005 10:53
Wohnort: Osnabrück
Kontaktdaten:

Re: STunnel und See4XB

Beitrag von andreas » Fr, 25. Sep 2020 13:40

Kannst du das Starten von stunnel nicht abschalten?

Evtl. die Anpassung mit dem Pfad auf den neuen stunnel zurück auf deinen internen stunnel ändern, die Configuration für deinen Email-Versand aus dem installierten rausnehmen und versuchen dann deinen stunnel parallel auszuführen.
Gruß,

Andreas
VIP der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15542
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 7 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: STunnel und See4XB

Beitrag von Martin Altmann » Fr, 25. Sep 2020 14:21

Das geht so leider nicht.
Ich würde gerne wissen, wie man bei See4xb das starten von STunnel verhindern kann, darum meine Frage.
Vielleicht darf ich in der Konfiguration ja XseeSetProxySSL() gar nicht nutzen?

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Scarmo
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 167
Registriert: Di, 24. Jul 2007 9:17

Re: STunnel und See4XB

Beitrag von Scarmo » Fr, 25. Sep 2020 14:27

Hallo Martin

Sorry, ich kann Dir leider auch nicht weiterhelfen. Aber ich würde doch einfach kurz ein Mail an MarshallSoft machen, die können Dir da bestimmt weiterhelfen.

Gruss
Marco

Benutzeravatar
andreas
Foren-Moderator
Foren-Moderator
Beiträge: 1843
Registriert: Mi, 28. Sep 2005 10:53
Wohnort: Osnabrück
Kontaktdaten:

Re: STunnel und See4XB

Beitrag von andreas » Fr, 25. Sep 2020 14:40

Notfalls ein Verzeichnis mit einer Dummy-Exe anlegen.
Gruß,

Andreas
VIP der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15542
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 7 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: STunnel und See4XB ERLEDIGT

Beitrag von Martin Altmann » Fr, 25. Sep 2020 18:06

Alles OK - habe mal wieder viel zu kompliziert gedacht (bzw. zu optimierend).
Wenn ich nicht versuche, die Konfiguration in die neue, permanent laufende STunnel-Installation zu übernehmen, klappt der Parallelbetrieb auch.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Antworten