ADS und Win Server 2016

Advantage Database Server

Moderator: Moderatoren

Antworten
Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2551
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

ADS und Win Server 2016

Beitrag von Wolfgang Ciriack » Mi, 25. Sep 2019 18:24

Hallo,
kann es sein, dass der ADS 11.1 Probleme auf einem Win 2016 Server hat ?
Habe bei einem Kunden das Problem, das teilweise - komischerweise nicht immer - das Programm sehr langsam läuft.
Wenn es langsam ist, dann auch auf dem Server lokal gestartet - womit wohl die Netzwerkverbindung ausgeschlossen ist.
Oder gibt es für den ADS 11.1 irgendwelche Patches, die man einspielen kann/sollte ?
Viele Grüße
Wolfgang

Benutzeravatar
nightcrawler
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 326
Registriert: Di, 24. Apr 2012 16:33
Wohnort: 72184 Weitingen
Kontaktdaten:

Re: ADS und Win Server 2016

Beitrag von nightcrawler » Do, 26. Sep 2019 13:53

Hallo Wolfgang,
die letzte ADS 11.1 Version, welche ich gefunden habe, ist die 11.10.0.30, allerdings nur .NET und Vulcan Verbesserungen. 11.10.0.24 bringt auch nichts, 11.10.0.22 Support für Windows 2012R2 und 8.1.
Die 11.10.0.20 hatte Fixes im Bereich Performance und CDX.

Download unter: http://devzone.advantagedatabase.com/dz ... Release=19.
Performance-Schwankungen sind erfahrungsgemäß schwer zu finden. Ich hatte bei großen Installationen mal versucht, über verschiedene SQL Skripte den aktuellen Zustand festzuhalten und dann später zu vergleichen (läuft der Speicher voll, sind viele Fehler geschrieben, Ist etwas mit dem Benutzerverhalten usw.). Die Analyse ist aber zeitaufwändig und bringt nicht immer den erwünschten Erfolg.
--
Joachim
Joachim Dürr Softwareengineering
https://www.jd-engineering.de

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2551
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: ADS und Win Server 2016

Beitrag von Wolfgang Ciriack » Fr, 27. Sep 2019 8:02

Hallo Joachim,
danke für die Infos. Da die Version 11.1 ja nicht für Win10/Server 2016 ist, meinst du, die Performance-Probleme könnten mit der 12.x behoben werden ?
Gibt es eine Testversion für mind. 15 User von der V12 zum Testen ?
Bevor ich Upgrade, würde ich es gerne Testen, ob es daran liegt.
Viele Grüße
Wolfgang

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13526
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: ADS und Win Server 2016

Beitrag von Jan » Fr, 27. Sep 2019 8:34

Hallo Wolfgang,

hier wird der ADS 12.02 auf Server 2016 benutzt. Irgendwelche Performanceprobleme haben wir noch nicht gesehen.

Wenn das bei Deinem Kunden nur sporadisch auftaucht: Läuft da vielleicht irgendwas im Hintergrund? Gerade mit Backups hatten wir schon heftige Probleme gehabt.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Joern
Rookie
Rookie
Beiträge: 6
Registriert: Di, 19. Jul 2011 9:31
Wohnort: Ebensfeld

Re: ADS und Win Server 2016

Beitrag von Joern » Fr, 27. Sep 2019 10:40

Hallo Wolfgang,

wir hatten in Verbindung mit Memo-Dateien Performance-Probleme.
Wenn die Memo-Dateien recht groß sind und in die Datei häufig geschrieben und gleichzeitig gelesen wird, hatten wir immer wieder eine Auslastung vom 100% und der Server hat nur noch langsam gearbeitet.

Was als Notlösung half war ein Pack, bis die Datei wieder anwuchs.


Deshalb haben wir Memo Felder bei uns entfernt.

Seitdem hatten wir bisher keine Problem mehr.


Vielleicht hilft dir das.

Joern
Gruß
Joern

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2551
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: ADS und Win Server 2016

Beitrag von Wolfgang Ciriack » Fr, 27. Sep 2019 14:01

Hallo Jan,
schön zu hören, das die Version 12.2 mit Server 2016 keine Probleme bringt.
Habe jetzt eine Demoversion 12.2, werden das nächste Woche testen.
Wir haben auf dem Server schon alles abgeschaltet, Virenscanner, etc. daran liegt es nicht.
Gestern haben wir noch einen Patch vom 11.1 eingespielt, bisher lief es damit erst mal besser.
Weitere Test folgen :D
An den Memodateien liegt es nicht, da habe ich nirgendwo bisher Probleme entdeckt.
Viele Grüße
Wolfgang

Antworten